Raytracing (directX12) and volumetric fog are not mixing together, arent they?

I noticed that godrays, very cinematic and beautiful feature of volumetric fog are not possible to achieve using raytracing. Or am I missing something? I’m able to create this effect with rhi Directx11 but not with DirectX12

My questions are:

  1. Is it something wrong with my computer? with my drivers, windows etc… or is this universal bug / feature / necessity ?
  2. Is there a workaround?

Steps to reproduce:

  • create blank project from3rd person template, ray trace disabled, desktop quality

  • delete all except chairs and floor (I don’t think that this step is necessary, but I wanted to go really from scratch, so I just kept meshes as something to cast shadow later)

  • add directional light, set volumetric scattering intensity to 30

  • add exp.height fog. Fog density set to 2, height fall of set to 2, volumetric fog checked enabled
    = godrays are present

  • go to project settings , raytracing check to enabled
    restart required
    after restart godrays are still there vut to truly enable raytracing (acording to documentation Real-Time Ray Tracing | Unreal Engine Documentation) you have to also set RHI to DirectX12, so…

  • go to project setting - rhi -set it to DirectX12

  • restart engine and there are no godrays in fog

I also tried to enable distance field meshes, thought was, that maybe it is needed t to generate them so they could cast shadows, but no success… but I don’t understand distance field meshes truly so maybe that is the mistake?

I also noticed that Quixels foliage looks really bad with anything other than DiretX12, translucency feels just wrong. So in the end, one is left with a choice to have nice foliage or to have god rays.

If you look at that page you linked, and search for volumetric fog, you’ll see that it is not currently supported. I’m trying to use Light Shafts from a directional light to get a similar effect, unfortunately though it’s only a screen space effect.

it is possible, sort of. Just turn off “Cast Raytraced Shadows” and turn on "Cast volumetric shadows for your Light you want to use for Godrays. This wont give you raytraced shadows from your light, but you have godrays…
Kind of a messy workaround, but better then nothing.
Raytraced Reflections for Surfaces are working as usual, only raytraced translucency is not supported yet