Download

raytraced shadows and bias

My raytraced shadows are not rendering completely because my camera is too far from my subject.
I know with depthmap shadows this is a bias issue but with rayracing this should not be an issue, it should be resolution independent.
Notice how the bottom of the buildings are missing are not casting shadows (red arrows), any ideas on how to fix that.bias2.jpg

Hey [USER=“1681534”]Heavy Metal Fox[/USER] , see my new post on the previous thread you made on the issue. Another important aspect of ray tracing that I’ve seen is not often accounted for is ray tracing in Unreal is a hybrid with raster techniques. Even if ray tracing is enabled in the project, and you are primarily using ray tracing in the post process and elsewhere in settings, it’s still a combination of it and raster. The notion that ray tracing works entirely by itself for a scene’s entire lighting / shadowing / reflections / translucency / etc is incorrect. If it was resolution independent to that extent, you should be seeing the shadows I think. So, the shadows aren’t rendering due to something in raster techniques AND / OR ray tracing. One thing to check, which could be easily overlooked, is if the buildings and the lights are all utilizing the proper lighting channels and that they’re enabled in the details panel of all objects and lights. Channels 0 and 1 are texturing and lightmap channels, respectively, so those channels need to be enabled per object and per light. If they’re not enabled in details panels for objects and lights, then it’s most likely they’re not rendering (actively displayed) in the scene.

Yeah I had a feeling it was not pure raytracing.
turning on channel 1 didn’t help, and as you can see up close everything looks fine.