Download

Ray tracing not working and no path tracer option

Hi.

I just downloaded the latest arch viz demo, theoretically it’s configured with ray tracing enabled, and I checked all the settings and they are fine.
The problem is that Ray Tracing is not affecting at all, and I have no “Path Tracer” option in the viewport menu.

As you can see from the picture, no raytracing lighting, no reflections, no path tracer option and everything enabled and configured.

I use an RTX2080Ti for ray tracing and I have Ray Tracing enabled in other projects of mine, so I’m not sure what’s happening.

Some ideas? this is latest 4.25.3

Thanks in advance for the help.

The Path Tracer is further down the list in the post process volume. It’s the second to the last dropdown, before Screen Percentage. It requires a bit of time, as I understand it, to gather light data and propagate the changes into the scene.

Ray Tracing Reflections is in the list of Rendering Features in the post process volume (PPV) too. Under Reflections, set it to Ray Tracing, then further down (below Screen Space Reflections) and under Ray Tracing Reflections, enable and set its values. Try at least 2 or 3 bounces to get better results, and increase samples if needed. A number of users have encountered bugs with the RT reflections and RT translucency, so if any are encountered when enabling (such as not working), do a search in the forums and docs to try some current workarounds and/or solutions.

With an RTX2080Ti, things should work efficiently. Remember that the Final Gather method of ray tracing is the quicker, less accurate method. Brute Force is a slower, more accurate method, and allows for changing the Max Bounces beyond 1, and Samples per Pixel from 16.

Thanks @presto423 :slight_smile:

​​​​​​​Yes, I know where the settings are, the problem is that they make no effect at all in the scene.

No raytraced reflections, no path tracer option in the viewport to enable it, according to the documentation it should be in the menu where I’m pointint at, and it’s not there.
If I change from Final Gather to the other option there is no change at all, I tried changing bounces, samples, etc… in the end, there is no ray tracing being done at all, it’s like if it were disabled, but it’s enabled.

I had this exact issue and this is what I did to fix it. It was a process of deleting configs first then disabling/restart and enabling ray tracing/restart and making sure Direct X 12 was selected.