Ray Tracing - Crash inside the platform compiler

Hi there everyone,

I’m having some frustrating issues with my UE4 - whenever I turn on Ray Tracing and SkinCache Compile Shaders in a project, the splash loading screen gets to 95% but then crashes during shader compilation.

The error that appears should be attached as an image -

“Crash inside the platform compiler!
Internal error or exception inside dxcompiler.dll”

I came to the conclusion that it was RayTracing and SkinCache causing the error as whenever I turn them on in new or existing projects, the crash on start up happens.
The only way to make the project open again is to delete the ‘DefaultEngine.ini’ config file, which obviously is what stores the ‘enable’ function for those features.

Any help on this would be great as it is currently preventing me from working on any Ray Traced projects.

I have updated my nVidia drivers and I am using a 3080 card. This error happens in both 4.26 and 4.27 projects.

Thank you!

Here is the second part of the error (which comes up in the Output log / where I can choose to send to Epic etc.)


Assertion failed: (Index >= 0) & (Index < ArrayNum) [File:D:\Build\++UE4\Sync\Engine\Source\Runtime\Core\Public\Containers/Array.h] [Line: 703] Array index out of bounds: 0 from an array of size 0


Did anyone get a solution to this issue?

1 Like

Having the EXACT same issue. I have disabled the Ray tracing, that’s how I could reopen it.

Any solution to this??


1 Like

Have you guys been able to fix this? I am getting the same error…

Windows 11, 3090ti here with an i9-12700KF

This started to happen after I got a new motherboard along with the new processor…
Worked perfectly fine on Windows 11, 3090ti with the 8700K…

update bios

I have this same error, did you find a fix?

I solved this by:

  1. Update BIOS (I don’t know this is actually help or not, I just updated it)
  2. Re-install the Nvidia Drivers, with the “Clean Install” option enabled.

I had the same problem. I removed the engine (Launcher/Library/Engine Versions/Current Version → Remove

Then I reinstalled it and now it works.

Good luck,


I had the same issue. After switching every file from hdd to ssd it worked.