Ray traced transluency issue

Hi, I have basic glass material (Base Colour, Rougness, Opacity and IOR), ray tracing allowed in project (DX12, use hw ray tracing etc.) and transluency setup to ray tracing in post process volume.

When I apply the material on the glass door the room behind the door (even though it’s completely dark) is rendered in way similar to unlit mode → very bright, no GI etc. When I switch to detail lighting or wireframe (!!!) mode the room behind the glass door renders the same way (even textures remain). When I enter the room it renders correctly but the rendering issue now appears on the other side of the glass as well. Hope this makes sense.


Uploading: yfdhyc5xkry81.png…

Additionaly, material (even in preview) is still transparent even with Roughness set to 1.

None of the above happens when I switch to Path Tracer → everything works as it should.

Any ideas?

Thank you!

The only workaround that I found was to turn off refraction in the Ray Tracing Translucency settings and turn off Affect Ray Tracing Reflections in the skylight component . Its not a perfect solution but It works pretty well.