Download

Rain sound fade in fade out ?

Hi , so i added a sound cue component for rain sound in a sky blueprint . And when the rain is activated in the bp , i activate the sound cue (and deactivate it for the other weather options like sunny , partly cloudy , etc… , and this works , but the sound abruptly starts and stops . So i tried adding a fade in and fade out node , but once i add that then no sound plays at all. So the first pick with just activate node works but has the abrupt start and stop on deactivate likewise , but when i add the node like in 2nd pic , no sound plays at all . I tried it with the fade in node both in front of the " activate" node and where it is in the 2nd pic , but no sound plays. Am i missing something?

On the right there , i also tried adding the fades on the " On component activated " and " On component deactivated " options , and the sound does play then , but it dont seem to fade out , just abrupt stop.

I would work directly into the cue and set up attenuation / a volume level.

You could also keep it starting abruptly and mask the start with a thunder btw.

(crazy, I know,) you could setup for a rain niagara emitter to play a single drop sound any time a drop touches.
you’d easily be killing the buffer this way, so you’d have to implement a cue pool.

The default sound cue limit was somewhere around 40. So theoretically you could just limit the amount of cues to 20 and have plenty remaining for additional audio.

A single drop sound probably lasts .02 seconds. If even. So the result should be just as convincing.

Niagara audio stuff you’d need.

The reason I would do this, is that you can have dynamic rain by just changing the surface sound and attenuation / air absorption values on the cues based on the rain drop parameters niagara provides, as well as being able to play a different sound based on the surface type that gets hit. Metal, water, dirt, sand. Etc.

Vs playing the same rain track loop.

As a bonus, you can extend this to a single water drip. Which can be useful for caves.

Thanks , any easier way? I mean shouldn’t i be able to just fade it out there?:slight_smile:

Yea, you could do the fade manually by throwing in a timeline and set volume multiplier.
start with volume multiplided to 0.
then the play.
Then the timeline to fade in.

the only other reason I can think of that would keep the engine node from working would be a bad sound cue that isn’t set to loop.
well that, and… if it’s .26 I believe they made some audio “improvements”…

I found all one has to do is tick the override attentuation settings box in the details , then the sound automatically fades in and out as entering and leaving the sphere radius.