Ragdoll moving still after set simulate physics?

So after the character mesh falls to the floor you can still see the hands and shoulder sockets moving around as if the animations are still playing. I have tried everything I can but nothing works. How do I stop this?

You can disable simulation by using “Set Simulate Physics” for mesh.Just untick “Simulate” bool.

I still want the physics to simulate but when it does some parts of the mesh are trying to move still like it is playing animations at the same time. I have tried everything to stop the animations but nothing works :frowning:

Here is a video


I put a ‘blend pose by bool’ in the animgraph which is controlled by the pawns health. The ‘true’ pose isn’t connected to anything which stops all animation when the character is dead.

Interesting.Dead man’s moving fingers…

I guess that finger movement comes from UE Guy’s idle animation.First solution comes to my mind is messing with state machine to interrupt/remove idle animation from character when he is dead. However I’m a stranger to that field.

Maybe you can add a bool to check if he is alive or not and then add this requsite to play idle animation.

You can also set component tick enabled = false. Then it will not move for sure, and also save some on performance.

Hey, set component tick enabled = false works as intended and it’s awesome, but the freezed body is still sliding on the floor. Any ideas how to overcome this?

I tried switching off simulate physics at the end but then the body switches to the freezed walking position.