Download

Quite a bit of light, for no lights!

Hi I am trying to create a lightweight material for mobile… I have the two materials set to Default Lit and Fully Rough. I deleted all base components and tried to add one point light to illuminate part of the scene. Even with the light disabled, it appears the objects are still lit somehow… so how can I make this look more like Unity, where without a lightsource everything is quite dark?

UE 4

Unity

Is there more to UE’s materials that I am unaware of or is there some global lighting setting I am missing? My material looks like this: Texture Sample -> Base Color. It’s as simple as I could think of.

Hmmm, neither of those screenshots look very good. It sounds like you’re not familiar with Lightmass at all, so I’ll start with the basics. If you are using static lighting, which is the default, you need to BUILD the lighting before it shows its final form. You do that by clicking the build button up at the top of the editor. You’ll get better results if you put a Lightmass Importance Volume surrounding your level. Volumes -> Lightmass Importance Volume ] If that doesn’t work, we might like to see the settings on your lights and materials. I don’t know why things wouldn’t work right off the bat.

First of all, make sure you’re in ‘Lit’ mode (top left of the viewport). If it says Unlit, everything will appear without lighting.

Secondly, if you have already baked lightmaps, some of them will remain showing even when you delete all the lights. I’m not sure why that is, I guess UE has trouble purging the lightmass info when you delete light sources, but you’ll have to build lighting again to purge the old lightmaps.

Hi, the second screenshot was from the Unity 3d engine, which was what I was more trying to emulate with Unreal. I don’t want a sun light, and want it naturally dark so that when I do add lights, it would illuminate the scene. That was the idea anyway.

I did not have a lightmass importance volume, but I added one with default settings sized to fit. I enabled the light (it was off in my original post, as I was trying to figure out where the light was coming from) so you can see its affect. I think something is decently wrong with my lighting setup, because if I move one of the cubes when I play the game it does not warn lighting needs to be rebuilt. I tried rebuilding anyway with no visible result.

Screenshots are a bit cut off, I tried to fit as much relevant fields as my screen would allow… and cropped.
Pointlight setting (only light): http://i.imgur.com/ZvsVFZf.png
Floor setting: http://i.imgur.com/pPuiCKI.png
Cube setting: http://i.imgur.com/g36TCZi.png
Floor material: http://i.imgur.com/N59MsUl.png
Cube material (basically same as floor, just no uv scaling): http://i.imgur.com/RjUgVPZ.png

I tried enabling/disabling mobile hdr but that had no visible effect. I’m only using static lights anyhow, which I don’t think requires mobile hdr.

Yes it is lit mode and I have tried rebuilding light. I think I mucked up a setting somewhere maybe…

In your World settings under Lightmass, check your environment intensity, turning it down to zero, with no lights, should mean a completely dark level.

Like TheJamsh said, delete the light and build the lighting again to clear the scene of any light data. You might have fiddled with a random advanced setting on that point light that blows it out. If you have zero lights and your lighting build (set to Medium or higher just in case) still comes out lit, then I’m not quite sure.

Thank you! This was exactly it.

Hey guys, we’re running into a similar issue in one of our studios’ projects. We have a Landscape in a level that previously had built lighting, we reduced environment intensity to zero, deleted the post-process volume, and deleted all the lights, but when we play in the editor, the landscape still has that blue environment colour applied to it, and we cannot for the life of us figure out how to get rid of it. We even went into World Settings and hit ‘Force No Pre-Computed Lighting’, and still it persists.

The only thing I can assume is that there’s a built lighting cache stored somewhere that isn’t being removed. Any idea where we should look or what to try next?