Download

Quick Note: How to manually override the Steam PublishedFileID for your Map/Mod

A quick note:

In case the ARK Dev Kit loses track (through a reinstallation or error) of the Steam FileID that you want to upload your Map/Mod to (you can see the ID on SteamWorkshop URL, ala http://steamcommunity.com/sharedfiles/filedetails/?id=478227612 ), then all you need to do is open this file in Notepad (when the ARK Dev Kit is closed):

\SteamLibrary\steamapps\common\ARKDevKit\Projects\ShooterGame\Saved\Mods.db

Find the section for your Map/Mod after you’ve attempted an upload:

	{
		"ModDir": "GenericMod",
		"Maps": "GenericMod",
		"Title": "The Lost World (Updated v188 fixed!)",
		"Description": "Install and run this mod to play on the ARK Island with only primitive-tier technology! ",
		"PreviewImage": "C:/Users/Administrator/Desktop/TheLostWorld.png",
		"Visibility": "Public",
		"ChangeNotes": "",
		**"ItemSeamId": "478227612"**
	},

And then change ItemSeamId (haha typo) to whatever Steam Workshop File ID that you want. Then launch the ARK Dev Kit, Upload, and it should upload to whatever SteamID you wish, as long as your logged-in user has permission to publish to that ID :slight_smile:

Cheers,
Drake

i wish I would’ve know that 4 days ago… lol. Thank you!

Ah, that does help. Thanks.

hehe gotta fix that typo drake :stuck_out_tongue:

There’s always the possibility to upload your mod yourself through SteamCMD. Once it’s cooked, go to ARKDevKit\ModTools\ModConfigs and edit or create a new file called <YourMod>.vdf. Here is an example:


"workshopitem"
{
	"appid"		"346110"
	"contentfolder"		"F:\\Steam\\steamapps\\common\\ARKDevKit\\ModTools\\Output\\TestMod\\CookedMods\\TestMod"
	"previewfile"		"F:\\Steam\\steamapps\\common\\ARKDevKit\\ModTools\\Output\\TestMod\\CookedMods\\TestMod\\preview.jpg"
	"visibility"		"2"
	"title"		"Test Mod"
	"description"		"Test"
	"changenote"		""
"publishedfileid" "487564899"
}

Visibility 2 is hidden, 1 is friends only and 0 is public.

Once you set up the VDF file, go to ARKDevKit\ModTools\SteamCMD and start steamcmd.exe. Use the following commands:


login user password
workshop_build_item "Full path to your VDF file"
quit

Thanks for the Information

I’ve tried to use this with the upload tool in the dev kit and it ended up resulting in creating a new app id each time, I would close the dev kit, modify the mods.db file then open the dev kit and it would lose all changes i’ve made, title|description|image and I would have to put them in again and it would just generate a new steamID

Needed to edit the .vdf file instead then I had to actually go and use the steamCMD.exe and use workshop_build_item \Steam\steamapps\common\ArkDevKit\ModTools\ModConfigs[modname].vdf

So, something here is wrong, as soon as i edit that file with a normal text editor, the dev kit creates a clean one
if i edit it with EG scite i have shitloads of “NULL” symbols between each letter and editing the file still causes the creation of a clean one
well i cant update my mod now at all

even manual upload with steamcmd doesnt work for “some” reason
https://goo.gl/fgoUU5

bumb :S i still couldnt fix it

Well, you also need to edit this file! ARKDevKit\Projects\ShooterGame\Saved\Mods.db
I always edit both files (also ARKDevKit\ModTools\ModConfigs\Your_Mod.vdf) and then just normally use the ark dev kit cooking tool, it always works (even if the ark dev kit is opened, just the cooking window needs to be closed)

what editor do you use for Mods.db?`as all i tried seem ti invalidate its encoding thus letting the dev kit reset the file

I’m having the same problem. Changing the Id, even in both the mods.db and .vdf file, lead to the id and all other details being wiped :frowning:

The only way I have been able to get this to work is to do a full cook, then upload my mod as “hidden”. Once it is uploaded, I go into the files and edit the vdf (located in ARKDevKit\ModTools\ModConfigs). Then I can use SteamCMD to upload my mod to the correct place. Doing it in any other order has always given me some errors. (I then delete the hidden mod on steam since I don’t want multiple copies flying around)

I use Notepad++
I never get problems editing those files with that editor. I can upload with the build in cooker in ark dev kit.

changed with notepad++ file stays alive, but upload fails “file not found”
and yes i double tripple infinite checked the fileId

Have you tried to do it manually with steamCMD, it just seems to work a lot better then the inbuilt uploader.

If you are using windows, don’t load it by double clicking, use command prompt and navigate to it, that way you can copy your path to the .vdf files with windows explorer, then right click paste (or just right click with win10 or newer versions of command prompt)

login [username] [password]
workshop_build_item [path to file]\Modname.vdf
exit
exit

done.

this is what happens

I’ve got it working now but only if I place the .vdf file and referenced picture in the same folder as steamcmd.exe. Seems like I’m stuck using that now instead of the dev kit upload.

Yeah sorry this does not work. The devkit overwrites any changes made to the db file. So if you lose the settings somehow like I did. You are going to have to not use the devkit uploader.

Every time I update my project I have to use the dev kit and upload with a new file Id as a hidden file. Then I edit the .vdf file with the correct file id and use steamcmd to upload again. Then delete the duplicate with the wrong ID. It works for me every time, but really this needs to be looked into as it seems to be a hack way of making an update.

what is GUID?
do I need to clear this?