Quick noob question: How to set completely white World/Environment color?

Hi all,
I’ve this scene ready to export in html5…or at least to test it on browsers :stuck_out_tongue:
Really noob question: how to set the world color to completely white?
The lightmapping and scene lighting is perfect. I just want to set white background to match the white of the browser.

As you can see on the image attached, I already set Environment color to full white.
What I’m doing wrong?


Just use sky sphere with white emissive material.

Or just use a cube, scale it to be very big and give it a white and unlit material. Make sure the normals of the cube face inwards. Or make the material two-sided.

I doubt an emissive material will look the same due to the tonemapper.

Its crazy it’s not just a matter of “set white/colored plain background=done”. With a white emissive material is anyway impossible to get full white background.

What you need to disable is the tonemapper. There are a few ways to do revert its change, or completely shutting it off. Just search for “disable tonemapper” and you will get various methods posted in forums and answerhub.

Disabling the tonemapper is an engine-side thing I am afraid.

Hello, I know this post is on the older side but I made a tutorial on how to make the background any solid color very easily.
Hopefully, this helps anyone who finds this thread in the future :slight_smile:

I’ll also include steps below for anyone who doesn’t want to watch a video.
1 - Delete default skybox
2 - Drag in exponential height fog
3 - Set Fog Height Falloff to zero
4 - Turn off atmosphere sunlight in light source
5 - Adjust fog instancing color to whatever you want

1 Like

I use a default game template and for some reason, a while emissive unilt material is grey, and the above height fog trick also turns slightly grey…

Even the built-in Default Shape Material is more white than unlit emissive…

Anyone know what’s going on? (EDIT: Oh… this “tonemapper” thing… very annoying that this is such a complicated question!)