Download

Questions about lightmaps and dynamic shadows.

Hey guys,

Maybe someone here can help me with this.

  1. Why are there seams on a landscape from a lightmap bake? Here is a pic to show what I mean. Landscape was created in Unreal. I’v also noticed sometimes the shadows from a mesh come out very strange or not at all on the terrain. Anyone know what that is?

b67ba43397fc66d1833eeaa35f6ffa0df20da2fb.jpeg

  1. I am getting a warning about dynamic shadows for a foliage mesh but I have no idea on how to turn them (the dynamic shadows) off. Here is a cap of the warning. Because of this, my trees don’t receive indirect lighting so its becoming a real pain playing the “find the button” game.

b940099aa187998603692e3cb9858d1d9de02fa6.jpeg

Any help would be appreciated.

I have seen nearly exactly the same problem in the udk forum, but unfortunately I can’t remind what was the solution :frowning:
**
For the problem with the seams:**
Do you have a lightmass importance volume in your level and have you already tried to increase the lightmap resolution of your landscape?

First problem is that your lightmap resolution is too low.

Second problem, I’m not sure, I haven’t messed with foliage, might be that they are all dynamic as a result of the tool that places them.

Hi Killer Ferret,

I’ve been playing around with some settings and seeing if I could give you some clear pointers on what to try out. In the attached images I’ve got two things for you to try.

In the first image I set up a basic Landscape with three trees of different sizes to clearly see the difference in shadow information.
In the landscape setting for “Static lighting resolution” I changed it from the default 1.0 to 4.0. You can choose to do this higher but I would not recommend raising this number too high as this would lead to long light build times.

In the second image I’ve opened up the static mesh for the tree (from the Mobile Temple example). I upped the lightmap resolution from 64 to 2048.

Also make sure to include a “Lightmass Importance Volume” surrounding your playable area as this will help reduce light build times. Playaround with these settings and you’ll get some better shadows from your meshes.

As for the the seam and the pre-shadows. I was able to reproduce the seam but when I upped the lightmap and rebuilt lighting it was no longer present. Not sure on the pre-shadows as I was not able to get that particular issue.

Let me know if anything else pops up or you have any questions. I’ll definitely do what I can do help you!

-Tim

850face019784cf19ee3449050c2853d0c1ebc28.jpegfd0caf282458ea25e9ee63cdcd674354486b9b68.jpeg

Thank you for the help guys, I really appreciate it.

I do have a light importance volume in the scene which it turns out is responsible for the warnings I am receiving as well as the lack of indirect lighting (turns out the volume was just too small). However the warnings still remain. I noticed that the newer builds look different than the older (I am guessing Beta?) ones. Someone posted a screenshot showing the “BCastDynamicShadow” button but it is no where to be found in the current builds. Anyone happen to know where it is?

On a positive note, bringing up the lightmap resolution did indeed fix the seam problem.

Matt

Yep, it was the Beta :wink:

It always depends where he did that (in a light, static mesh,…) because in the static mesh properties (when you place it) you can disable the “CastDynamicShadow” and also in the Sky Light and Directional Light (just use the search bar above the property tab

Hm, well I tried disabling dynamic shadows in the light properties but the warning still comes up. Because these meshes are instanced, I haven’t found a “cast dynamic shadows” button aside from the one that affects indirect lighting but that one is unchecked. Of course disabling shadows completely will fix it but wont look so good in the long run haha. I wonder if this is a bug or a feature that needs to be included in the instance editor in a future update.