Question on custom static meshes for Vive Motion Controllers

I’m following the tutorial located here. I can get it working fine if I use the built-in cone static meshes - i.e. I can see the cones in VR Preview mode. However, when I change the static mesh on one of the controllers to be a custom static mesh that I imported (which displays properly if I add it to the level), BOTH controllers stop rendering, i.e. I see nothing in VR preview.

What could be causing this?

I honestly have no clue but some shots out to left field:

Do you have collision on your mesh? Perhaps it reads that some how, honestly not sure.

Is your mesh too large/small? Could you be inside your mesh because it is so large (sounds silly but happens) and seeing through backfaces?

Perhaps its a material issue? Try using the default material.

Is your origin/pivot at a weird spot on your mesh? Perhaps it is just in an unexpected location?

Awesome, glad you found a fix.

I’m not sure the controllers would ever need blocking collision. You probably want them to always represent the proper location of the player’s hands. This is an oft discussed visual for the player to prevent disconnect from the real world. (May be jarring to have your “hands” stop when they are still moving in the real world). Of course everything is up for change based on game design.

OK I figured it out. I had collision enabled on the custom static mesh. When the game started, they were getting stuck under the floor because of where the player character spawns. Either I will need to disable collision or teleport them to the motion controllers in a Blueprint.

Disabled collision on the static mesh component as they were getting stuck under the floor when the player character spawned.