Download

[Question] How to get rid of these weird Shadow artifacts?

Hello Everyone,

I’m in the process of developing my game and I’ve came across a weird lighting glitch, Which is annoying me.

LandscapeTexture_Help.jpg

What are these things? How can I stop them? I have tried messing with lightmap resolution, building the lighting on various quality settings etc… But nothing works other than disabling casting shadows all together (Which obviously looks wrong.)

I have repositioned the mesh’s UVs making more use of the UV grid.

I just can’t seem to fix this and it’s quite annoying to be honest. So any help would be appreciated!

Increase resolution. Turn area shadow from stationary lights on. Increase dynamic shadow range.(this overrides static shadows for given range)

I really appreciate you replying, but could you elaborate a bit more please? :smiley:

The main light source is set to stationary already.

By increase resolution, Do you mean increasing the lightmap resolution of the mesh?

The only light source in this level is the directional light source, Is this having an effect?

How do I increase dynamic shadow range?

Do any of these settings have an impact on performance either?

Thanks again for replying.

If the light is stationary you can increase the “Light source angle” which will make the shadows softer which could help but may not be the solution you want.

by resolution jenny meant the resolution of the lightmaps on your ground/rocks. Stationary lights use distance field lightmaps which means they intepolate sort of using curves but can still recreate a sharp outline. With low resolution this causes a somewhat curvey but sharp silheoutte to meander a bit which is what you are seeing. Either softening of increasing res are best bets.

“Use Area Shadows for Stationary Lights”

Setting this does not affect performance.

You should have some source of indirect lighting so shadows won’t be black. Just add SkyLight actor there.

To me it looks like cascading shadow distance is too short (the default setting is very short, especially for exterior scenes)

If you get closer to the shadows, does the problem start to go away?

If my character approaches the meshes, The shadows stay the same, With those thick blobby looking artefacts.

What settings would you recommend I fiddle with then? :slight_smile:

Thank you for the help! :cool:

The scene is an outdoor scene, so does this skylight actor just need to be placed once?

Only one skylight is needed per level.

I meant for the camera/your view to get close, not a character pawn. Try that and see if the shadow changes.

I apologise if this is frustrating, But I’m not sure what you mean. The player character has a camera, I have been right up to them to inspect in the editor as well.