Download

quality lowering at camera distance

Hi,

i am rendering a cinematic in the sequencer but I am facing a problem that’s been driving me crazy for quite a while. When my camera moves backward, and the assets (architectural / outsied) gets farther, kind of a shadow keeps appearing on the meshes. It disappears when getting closer from the assets. I have tried CSM (but it’s supposed to be used on ly with dynamic or movable lighting) with no success. I’d like my assets to keep the same aspect from far to close

My setup is all static (sky, dir light, have a light mass importance volume). Culling disabled in project settings.

I have exploring lightmap size for each object (increasing it and thus exploding render times) but no change. I also tried LOD (by default, I hade none)

The only work around to my problem so far has been rendering my lighting, then changing my directional from baked to static (or movable to static or any chnage anyway). Then the engine tells me I have to render again (even though the solution is ok). I deactivate shadow preview warning and then I can render my sequence free of those ugly “distant based” shadows… It’s not hte best of the asnwers anyway…

Hope you can help me with this problem.

Can you post a picture or two showing the far shadow and when it’s not there?

@Presto423 2 pictures, hope it can help :

hi, just noticed the problem is the same with preview lighting after I deleted all the build datas in case it helps

I see the extra shadowing at the top and bottom edge of the relief underneath the roof. The problem is probably distance fields, though which particular aspect I’m not sure. Try opening the mesh for that relief in the mesh editor, increase distance field resolution under Build Settings. Increase the resolution by 1, and up to 3 or 4 at the most. If it works, then it’s only the one object and one take up a ton of memory. Another suggestion is enabling two-sided distance field only for the mesh. It generates a distance field with two sides to increase the accuracy of the occlusion and coverage of it.

If neither of those work, there’s a setting in the directional light that can be for adjusting shadowing of crevices and small, recessed areas at a distance. It’s called Ray Start Offset Depth Scale, is .003 by default, and should only be changed by a little bit because it affects everything in distance fields so it could alter other things in the level. I think it shouldn’t be necessary, but it could be worth it if it doesn’t change other shadowing for worse.

One alternative solution might be to place a rect light or lightmass portal over the incorrectly shadowed area and adjust the brightness so it doesn’t add more intensity to the result, but removes the overshadowing. Does the effect pop in when the camera moves to a certain distance away, or is it a smoother transition?

Hi,

It fades in when the camera moves to a certain distance. I’ll give a try to the settings you mentionned since this is only visible on this two instanced object (as you see on the left it’s almost the same geometry but no probleme on that one, even though it’s an instanced from other another model).

EDit : I after checking, I have no distance fields shadow enabled by in my project (cannot select this in my directional light)

Hi,

Can it be related to SSAO post process? Making SSAO calculated in world space would solve your problem. On default it’s screen space and can behave like this.

Hi, It could be AO indeed. How do I change it to world space ?

If you don’t have post process volume in your level, you should add it first and make it infinite (unbound). Then from ambient occlusion settings, there is a small arrow to open advanced settings of it. You will probably find it there, or you can just search in properties after selecting post process volume.

Since i don’t have unreal engine in front of me currently, i can’t send a screenshot for it. Sorry about that.

Here is the documentation link:

https://docs.unrealengine.com/en-US/…ion/index.html

You will find it as Radius in WorldSpace.

But i guess it’s more expensive compared to view space one.

@theknoppix Thanks, found this option in my postprocessvolume (I had one in my scene already) but I had not messed with AO in it.

I have fired another render in medium so I should know in about 1 hours from now if it’s ok… Let’s cross fingers ! My project has to be delivered by tomorrow morning

As long as my station can render cinematics in a steady 25 fps, it will be fine even though it’s heavy !

@Trucabulles No Problem, i hope it solves your problem.

@theknoppix I have just checked the render (on teamviewer, using a slow cellular connection so picture is quite bad) but it seems ok. I’ll check it carefully when back home in an hour or so and let you know so we can validate the answer here in case it can help other people.

Well, it was not this… problem still there :frowning:

Does the mesh have more than one LOD? LOD 0 is the default, highest-res LOD. I’ve seen it before, and I’m having a similar issue in a test project, but not identical. Neither distance field or AO settings changes have resolved it so far. I’m beginning to think it is a problem with the default camera for the editor, aka the viewport camera. It has defaults that are seemingly causing other problems too, such as tonemapping and anti-aliasing.

No LOD
I have the same probleme with cinecameras

Anti aliasing is pain in the neck in UE for me whatever the camera used.

I love to see more samples, this is wonderful!

Maybe Pixel Inspector can give you some hint about it.

@theknoppix Thanks.I didn’t that too., i’ll give it a look.