Quality dependent lightmass light leak

As soon as production quality lightmaps are calculated Lightmass messes up one particular area by putting some weird light there:


Top is production quality with the unexplained yellow light leaking in. Bottom is the preview quality with the expected lighting.
I’ve deleted the Intermediate and Saved folders but the issue shows up again at the same place.
I also tried some high def archviz lightmass settings (edited both ini files in the engine installation folder) but that didn’t help.

Hi ZoltanE,

Can you provide a little bit more information and perspective on your scene and setup for me?

  • Are you using static/Stationary lighting?
  • Are you using point/spot lights and can you show the scene with these lights in view, not the final rendered view, but editor?
  • Is the building walls a single mesh, or are these separate objects? If so, does the back wall extend past the ceiling part?
  • Is the floor a different color than the walls? If so, is it the yellowish color you’re seeing or is there another object in the room that is this yellowish color?

When using Preview there will only be a single bounce of light used by lightmass whereas Production will use the number of bounces listed in the World Settings under the Lightmass section or what is set in the BaseLightmass.ini file if you set it there.

Let me know your asnwers to the questions above. I may have a few more after this, based on your answers.

Thank you!


Thanks for the quick response!

The wall in question is affected by 2 instances of a neon light blueprint which has a dynamic pointlight in it. Other than that I have a stationary sun but the wall is facing away from it and the whole room is in shadow anyway, due to a big staticmesh cliff. There are other lights in the scene but they are localized and in other rooms.

Here is a view of the most important static meshes and lights in the area:


Red line indicates the position of the light leak.

The ceiling, floor and the walls are separate meshes. They are 25 cm thick and they overlap: the top of the wall lines up with the top side of the ceiling mesh. Same goes for all the other corners, I made sure everything is watertight. The overlapping area in each case is a separate quad with a separate lightmap UV island. That UV is scaled down to 1% of original to avoid wasting lightmaps on hidden areas. The same goes to other non visible parts like the top side of the ceiling.

I’m not sure what the yellow color comes from. The sun has a much less saturated color. Maybe if it was shining directly onto one of those yellow cupboards… But I don’t see how that would happen: the wall and the yellow side of the cupboard faces away from the sun. Other cupboards on the opposite wall might be able to color the environment but then the ceiling would be affected as well. Of course this is not going to happen the sunlight is blocked.

This error only shows up in production: preview, medium and high qualities are fine. Also I have clones of this level: they are exactly the same except have different lighting setups. They do not have this or any similar errors.

I guess I start removing parts of the map to see if anything changes… too bad production quality lighting takes 6 hours to complete so experimentation is really slow.

I would expect that if your ceiling lights are set to dynamic/movable that really that area should only be lit by direct lighting, which would not have any bounce light at all, but looking at top image these lights do not indicate they are set to movable. They appear to either be static/stationary because they are missing the 4 pronged movement arrows for dynamic lights.

Another consideration, if you don’t have a lightmass importance volume around your playable/accessible areas you may want to add this as well. This will give full lighting detail to these areas based on what’s set in the world settings and anything outside the volume will only get a single bounce of light and lower quality lightmaps since they won’t need full resolution.

When you start going through to remove things, try disabling Affects World on the directional light when you build. This can quickly see if there is something that the directional light is causing to bounce and leak into this area perhaps.

Maybe if there is any windows that are inside the area that could allow some extra bounce in that you maybe did not anticipate. If it is the Direcitonal light, you can always set the Indirect Lighting Saturation to a lower value to reduce the intensity of its bounce lighting.

You’re right sorry, those lights are indeed stationary with dynamic shadows.

A simplified level, where only this room and its immediate surroundings were left in, showcased the same leak but without the yellow tint. o_O Then I disabled the sun (stationary directional light) and the leak was gone. My current hackfix is a cube above the ceiling of the affected area, acting as an additional obstacle for the light.