Download

Proper use of Opacity? Translucency bug?

I have a wooden window frame with a transparent glass in the middle. My glass material contains some opacity values that gradient from 1 to 0 to get some grime around the window edges.

When I utilize translucency, my polygon faces become strangely inverted or back-faced. Is this a bug with Radeon cards as I get something similar in Maya? I’m using Radeon 7970m.

Can you share some screenshots both MTL, In game / immersive mode and in Maya? Would be easier for us to help.

Arg! I think I just fixed it. Give me a second. I’ll explain what I did :slight_smile:

Nope, false alarm. Here’s the screenshot. This is a single combined mesh with a transparent texture.

https://dl.dropboxusercontent.com/u/15865921/Trans_01.jpg

https://dl.dropboxusercontent.com/u/15865921/Trans_02.jpg

https://dl.dropboxusercontent.com/u/15865921/Trans_03.jpg

https://dl.dropboxusercontent.com/u/15865921/Trans_04.jpg

Doesn’t UE opacity work like black = translucent and white = opaque, I can see your glass is totaly black in that map anything in grey range will be more visible. Try white and multiply with a constant of .5 (etc) to get the right look would be my process but i am a mere FX artist, Also you might wish to try some SSS instead of simple translucent. There might be some examples of water and/or glass materials in your engine or in samples i would take those and look at how Epic has them set up and trying to replicate them by matching your needs. That is the best approach i can think of.

Yeah what I did was create a material as Translucent blend.

However, in this image below you can see the ‘sorting’ is messed up. The back is visible in front faces etc. I’m starting to think this is a bug for Radeon cards for some reason. It might not be, can someone confirm?

https://dl.dropboxusercontent.com/u/15865921/Trans_05.jpg

You may want to try using layered materials, one for the translucent surface and the other for the solid and change lighting mode to Surface for the translucent material

I’ll be exploring that option next except where it is transparent, it’s only one material on one face. the other objects are imported into the blueprint.

I have a radeon card and it works fine so its probably not the card.

I remember trying something similar to what your doing but I found that translucent materials never went truly opaque when using a mask witch gave me results like yours, you might do better using 2 materials, might work might not:)

Ok that’s a relief then. At least I know it’s something else. I might be doing the workflow wrong somewhere. I’ll keep myself posted in this thread. Just testing it on my mac to see if I can duplicate the result. It uses Nvidia card.