Project worked fine in UE 5 EA2, but crashes every time in 5.0, please help

Hi my game opened fine in Unreal Engine 5 EA1 and EA2, but as soon as 5.0 came out it started crashing immediately. I thought it might be something to do with the map, so changed the .ini so it would open a blank map, and it worked, but now, every time I even open a blank newly created blueprint actor, the engine crashes. I can’t open any blueprints at all, even a completely blank blueprint actor. If I open any map with any blueprint actors in them, it crashes too. I’m going to attach my crash log. Any help in figuring out whats causing my project to crash UE5 would be great thank you !
AncientSkyDemo.log (92.1 KB)

I saw in the log is not finding one of the maps, DLLs, and a few blueprints. Is it a C++ project?

It can be caused by various reasons, in my similar case, was due to missing plugins not installed or no longer available in the new UE5 build.

Hi thanks for the reply. It is a blueprint only project. I did have some plugins installed months ago when it was on 4.26, but the project still opened and seemed to work fine in Unreal Engine 5 Early Access 1 and Early Access 2 without any of the plugins from 4.26.

Have you tried to migrate your project to a blank one? It would be easier to check the log again and see if there is a particular file missing.

This part here shows the issue while attemping to create a new BP

[2022.04.24-03.56.45:598][518]LogSlate: Window ‘Pick Parent Class’ being destroyed
[2022.04.24-03.56.45:605][518]LogContentBrowser: Deferred new asset file creation: NewBlueprint
[2022.04.24-03.56.45:609][518]LogContentBrowser: Creating deferred item: NewBlueprint
[2022.04.24-03.56.45:623][519]LogContentBrowser: Renaming the item being created (Deferred Item: NewBlueprint).
[2022.04.24-03.56.47:117][671]LogContentBrowser: Attempting asset rename: NewBlueprint → NewBlueprint
[2022.04.24-03.56.47:122][671]LogContentBrowser: End creating deferred item NewBlueprint
[2022.04.24-03.56.47:834][750]LogAssetEditorSubsystem: Opening Asset editor for Blueprint /Game/DistantSkyData/NewBlueprint.NewBlueprint
[2022.04.24-03.56.47:834][750]LogChaos: FPhysicsSolverBase::AsyncDt:-1.000000
[2022.04.24-03.56.50:971][750]LogStall: Stall detector ‘UAssetEditorSubsystem::OpenEditorForAsset’ exceeded budget of 2.000000s, reporting…
[2022.04.24-03.56.50:971][750]LogStall: Stall detector ‘UAssetEditorSubsystem::OpenEditorForAsset’ report submitted, and took 0.049972s

When I tried using unreal engine’s migrate function inside the editor to migrate the content folder to a blank new project, unreal crashed again. I’ll try just copy and pasting the content folder in windows into a new project.

If you can, try to ‘cook’ you project and check the output log. It might shed a light on what is causing the crashes.

Same crashes when I copy and pasted the content folder into a blank project. I’m trying a package and cook in the project launcher now, ill post the output log when it fails or finishes, thanks

Yes, let’s see what happens. Good luck.

thanks, here is the end part of the launcher log, I copy and pasted all the red errors into a text txt file
launchLog.txt (13.0 KB)

Have you updated from EA02 to UE5? I heard other users uninstalled EA2 and installed UE5 in a blank slate. There is a critical error, perhaps reinstalling the Engine might help. Now it is at UE5.0.1

LogWindows: Error: begin: stack for UAT
LogWindows: Error: === Critical error: ===
LogWindows: Error:
LogWindows: Error: Ensure condition failed: !UberGraphFramePointerProperty == !UberGraphFunction [File:D:\build++UE5\Sync\Engine\Source\Runtime\Engine\Private\BlueprintGeneratedClass.cpp] [Line: 1357]
LogWindows: Error:

I did update from EA02 to UE 5.0, and then to UE 5.0.1. The crashing with my project started happening in UE 5.0 and continued in 5.0.1. Blank template projects seem to work fine in 5.0 and 5.0.1, but ill try uninstalling 5.0.1 and reinstalling it, thanks for the suggestion

Perhaps that should work. I did a quick search and saw other users complaining about 5.0.1 crashes, not sure if it is related to your case. I am still on 5.0.0. Hope that helps you. Good luck.

Uninstalled and reinstalled 5.0.1, unfortunately the project still crashes like before. The errors in the log look the same. Hmm

This is unexpected. If you can work to eliminate the warnings, that should also help. Then, you may want to try cooking again. I had to fix all the warnings in my project, from missing textures in materials and particle systems, animation compression errors, etc., to be able to launch my project. Also, these crashes can also be caused when renaming, moving, or deleting files or variables (mainly structures), which can break the references and cause compiling errors and further crashes. If you can recall the last blueprint files you had modified may also help.

Let’s see if other users or the forum moderators can help you with the other error messages and the critical error message.

democannonproj.uasset: [Compiler] Function ’ Ignore Actor when Moving ’ is unsafe to call in a construction script.
LogStaticMesh: Warning: Mesh SM_CoinStack_01 is recomputing physics on load. It must be resaved before it will cook deterministically. Please resave /Game/MoneyPack_01/Meshes/Coins/SM_CoinStack_01.SM_CoinStack_01.
LogStaticMesh: Warning: Mesh SM_CoinStack_04 is recomputing physics on load. It must be resaved before it will cook deterministically. Please resave /Game/MoneyPack_01/Meshes/Coins/SM_CoinStack_04.SM_CoinStack_04.
LogStaticMesh: Warning: Mesh SM_CoinStack_03 is recomputing physics on load. It must be resaved before it will cook deterministically. Please resave /Game/MoneyPack_01/Meshes/Coins/SM_CoinStack_03.SM_CoinStack_03.

LogBlueprint: Warning: [AssetLog] D:\UnrealProjects\AncientSky5\Content\UltraDynamicSky\Blueprints\Ultra_Dynamic_Sky.uasset: [Compiler] Set Reflection Sample Count Scale : Usage of ‘Set Reflection Sample Count Scale’ has been deprecated. This function has been replaced by SetReflectionViewSampleCountScale.
LogBlueprint: Warning: [AssetLog] D:\UnrealProjects\AncientSky5\Content\UltraDynamicSky\Blueprints\Ultra_Dynamic_Sky.uasset: [Compiler] Set Shadow Reflection Sample Count Scale : Usage of ‘Set Shadow Reflection Sample Count Scale’ has been deprecated. This function has been replaced by SetShadowReflectionViewSampleCountScale.

Missing cached shadermap for cruiserextras
Missing cached shadermap for MI_AC_Circle2

Copy and past the contents of the /Content folder into a new project’s /Content folder.

Hi thanks for the reply. I tried copy and pasting the content folder into a new blank project, but unfortunately the crashes continued to happen in the new project as well.

You are sure that you used a fresh empty project without any edits and settings changed?

Definitely sure, created a blank blueprint project with Unreal Engine 5.0.1, copied the content folder of my old project and pasted it into the new project, opened the new project, but still whenever I open a blank blueprint actor, or any blueprint class, the editor crashes.

Make a fresh 5.0.1 install, meaning uninstall UE5, then re-add it - instead of upgrading a UE5 EA build.