Project says UE4Editor-projectname.dll is missing or built with different engine version

I am using 4.10 and this project is just a light modification of ThirdPersonView blueprint. All it has is a couple of actors with a blueprint that makes them rotate.

It happened when I tried to make a C++ empty class. The editor froze for 10+ minutes and I had no choice but to kill the process (it wasn’t even using my CPU). When I tried to open it up after that the project itself says, “UE4Editor-projectname.dll is missing or built with different engine version. Would you like to recompile it?” When I click on yes it says it failed. I am not sure how to go about this because editor won’t even open.

I’ve ran into more issues like this with 4.10 in the past few days than I did with 4.9.2 for almost two weeks. Does UE just hate me or something?

One thing you can try is navigating to your project’s folder and open the ProjectName.sln file. the .sln file is a visual studio solution and from there you can compile the game. I’ve noticed that when you start a project as blueprint only, the editor and visual studio seem to get over populated with information. The visual studio overload is caused by intellisense being populated and the editor overload is caused by it being populated with every class that exists in the engine.

My sln file is missing. It is there for other projects, but it is gone for this project.

Try deleting the .dll files in your Binaries folder. The editor “should” launch without them, from there you could probably regenerate the visual studio project files.

It worked for one project, but suddenly another project gave me this exact same issue and nothing fixed it… I wonder if UE 4.10 is really buggy or if I just have bad luck. I’ll mark your answer right because it did work 1 out of 2 times.

Quick question. Where is this “Binaries” folder?

Hi, in my case the issue was that my compilation was not creating the file UE4Editor-projectname.dll anymore.

This is because I was missing this line in \Source\MyProjectEditor.Target.cs:


Without this line the compilation succeed, but UE4Editor-projectname.dll is not created.