Project not compiling after upgrading to 4.26.1


I have been working on a project in UE 4.25.4 for a while now, which has always worked fine. I am now trying to upgrade to 4.26.1, but when I do so it no longer compiles. I previously received some messages that certain code would be deprecated, but that has all been solved. I have tried upgrading via the launcher, as well as via right-clicking the .uproject file and changing the engine version, but both give the same errors. The full output can be found here.
The weird thing is that it compiles and builds just fine in 4.25, but not in 4.26. When then switching the project back to 4.25, it works again. The issue seems to be in the Niagara plugin code, which I have not altered in any way. I also can’t find anything on google about changes to Niagara that would stop it from working in the new version. When trying to build in VS, the same error is thrown, but again only when running the newer engine version.

Any ideas would be much appreciated, as I am at a loss here.

Changing engine versions causes a large array of problems because new engine versions usually have new ways of using older systems. A lot of code changes and fixes have been made.

So you’ll have to scrub through your project and see exactly what systems were broken and individually fix each system. For instance, moving from .24 to .25, ALL lighting was broken. You had to go in and re-add and re-do all manually placed lighting. It was incredibly annoying.

But there’s a strong chance is a basic system like that that’s not working properly. You’ll have to search for whatever is broken manually.

While disabling the Niagara plugin and removing all code and assets related to it did make the project compile and build in the new version, I don’t think that was actually the root of the problem on its own. I tried upgrading the project on a different machine, which worked perfectly. When trying to open this upgraded project on the first machine, it saw it as the older version still, and gave the same errors when trying to build.

After many hours of trying all kinds of things it is now working however! The last thing I tried was just completely uninstalling the launcher and both versions of unreal, and only installing the latest version. It then still saw the project as being on the older version, but did manage to upgrade it and build it successfully somehow.

So I still have no clue what the actual problem and solution were, but at least it is working now :slight_smile: