Project Crashing On Startup

My project was working fine until all of a sudden the animations started glitching and ue4 crashed. Now every time I attempt to open the game it crashes… I read through the crash logs and this it what I found:

LogWindows: Failed to load ‘aqProf.dll’ (GetLastError=126)

LogWindows: File ‘aqProf.dll’ does not exist

LogWindows: Failed to load ‘VSPerf140.dll’ (GetLastError=126)

LogWindows: File ‘VSPerf140.dll’ does not exist

LogWindows: Failed to load ‘VtuneApi.dll’ (GetLastError=126)

LogWindows: File ‘VtuneApi.dll’ does not exist

LogWindows: Failed to load ‘VtuneApi32e.dll’ (GetLastError=126)

LogWindows: File ‘VtuneApi32e.dll’ does not exist

And I would like to mention that I can launch the game to play, and I can launch other projects to edit. Only when I open the project to edit will ue4 crash.

hmm this is weird, all of my crash reports from when the game was working have this too.

I don’t really know what they error is then.

this dosent work on other computers.

sry, the project wont launch on any computers.

I finally fixed this issue, I just had to delete my saved and intermediate folders.

I’m trying to open Epic Games Launcher and I get a black screen with the following error in the log file
Failed to load ‘aqProf.dll’ (GetLastError=126)
LogWindows: File ‘aqProf.dll’ does not exist
LogWindows: Failed to load ‘VSPerf140.dll’ (GetLastError=126)
LogWindows: File ‘VSPerf140.dll’ does not exist
LogWindows: Failed to load ‘VtuneApi.dll’ (GetLastError=126)
LogWindows: File ‘VtuneApi.dll’ does not exist
LogWindows: Failed to load ‘VtuneApi32e.dll’ (GetLastError=126)
LogWindows: File ‘VtuneApi32e.dll’ does not exist

What do I need to do to rectify please?

okay, so I looked into all my crashes and it seems those .dll files are listed as errors but are not the direct reason for them crashing. To fix this issue go in to you project folder under (documents/unreal projects/PROJECT NAME). And delete the “intermediate” and “saved” folders.

At the first time tha game was started but now I have the yours problem…
I tryed to delete the folders but the game doesn’t go… please help me.

Same for me. I deleted those folders and it didn’t help.

I am having the same problem ! Please help me to fix it

Same for me. Both folder have been deleted, but i steel have the crash when i launch Fortnite. Is there another way to correct it?

It doesn’t work.After I deleted the “intermediate” and “saved” folders and the crash happened again.

I have the solution: you must go into management devices on your pc and disable your intel video’s and only if you have Nvidia on your pc.

perform this procedure only if you have Nvidia in your PC together with another video card intel
disable the intel card and this will start Nvidia

I do not take responsibility if you cause damage to your PC

I think I FINALLY found out why it’s crashing. I was getting the exact same .dll errors as you all were. It happened over and over again. I ended up having to rollback my project 4 of 5 different times.

Answer: The problem was with my code. For example one time I had a TArray, in which I was trying call a function on an index and it was a nullptr. When I compiled it crashed with those errors. At the time I was unaware of my logic error. I kept deleting the binaries/saved/intermediate files, but the project would still crash when loading with those .dll errors. I ended up fixing the code saving the .cpp files and .h files and it worked. I wasn’t 100% sure this was the answer, but the crash happened to me again…

I was calling PostInitProperties on a derived class I created, but I wasn’t calling the Super(). Once I fixed my .cpp and .h and then went through the deleting of the saved/intermediate/files. Then started my project it worked.

So I would suggest looking at your code, that’s most likely the reason it’s crashing.

I have no idea how to code honestly this all sounded confusing af If you dont mind please tell me how to fix this in code just write out instructions or add me on discord Richcarlos#6271 ty this is much apreciated

nope, this don’t help at all. Maybe a epic bug?

Hello guys;
I don’t play games but my architectural render program (OS Windows10) works with Unreal as render engine and I came across the exact same problem. After half a day of trying and cleaning registries and all I thought of an old bushtrick; create another user for Windows on your computer; log into that one and start the software.

Worked for me.

It’s not long term solution, but at least I could continue…

Greetings from sunny Amsterdam.

Attn: coders: especially those used to higher-level languages (raises hand)

This is probably the answer. Until you truly are used to UEc++ (it is its own beast), just put nullptr checks EVERYWHERE. I’m looking for the ‘best practices’ check, but I know it uses ensure. Simple “== nullptr” checks can break the things because… UEc++. I’ll edit/reply when I find it.