Project crashes on startup on other computers

So this is very weird- I copied my project to my home computer so I can work on it, but it crashes when it tries to open. However, on my main computer that I was working on, it works! I tested this on my laptop as well. I have no idea what is causing this, and would appreciate it if someone can help!

I included the log (or at least I think it’s the right one).

link text

First, check your Levels directory for any file named HPS_BuiltData. There should only be one and it should be named HPS_BuiltData.uasset. If it’s not named that then rename it. Otherwise, delete it.

If the file isn’t there or that doesn’t work, try moving the HPS.umap file out of the project directory tree entirely.

Yeah there’s no builtdata files in my Levels directory. Moving the umap file out of the directory didn’t seem to do anything.

You think the builtdata files are maybe what’s causing it to crash? From looking at the logs, looks like it’s trying to find them but can’t. I’ll have to check the main computer tomorrow and see if those files are there. Though the thing is I did archive the entire project folder too to test it on the other computer and it still crashes. Hmm…

It’s complaining but that doesn’t mean it’s the problem. UE4 generates that data if it’s not there. I mean, I can load a level without it having a BuiltData file. Still, it was worth trying.

Maybe check your .ini files for any reference to the BuiltData file and remove them?

But I think we need to look elsewhere. Find the crash log file and post that.

Any logs other than the one I posted that would help? There are 3 other files in the crash report folder, and not sure if they would help. Attached a screenshot of them.

Use this: A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums

Sometimes the crash logs aren’t there but somewhere else. Hopefully not for you.

You can also look on the web and determine where Windows puts its crash logs. It’s probably a service with an app to browse the logs, actually.

Ok I’ll take a look when I get a chance. Still really strange how it works fine on one computer but not any others. Hopefully when I find the log it’ll give me insight.

Let me know. Also, how did you transfer the project? Did you package a zip from the editor? Did you copy the entire project (including Intermediate/Saved)?

Unfortunately I browsed to the locations of the crash logs specified from the link you gave me, and the folder is empty.

I copied the project by zipping the entire project folder from the root level, so it got everything.

Anything else that could be worth trying looking into?

Thanks!

That could be your problem. On the PC that works, go into the editor, choose File->Package Project->Zip up project. Copy the zip to the other PC and do the usual Generate Project Files and build process.

The directories that UE4 generates will not necessarily work between installations.

Hm interesting. It’s strange because I’ve done this before with many other projects and it worked. This is the first time I ran into this.

The only other key difference is that this project is being maintained through a Git repo. I was able to work fine until I got to a certain commit where I implemented some UMG / UI features.

For the Generate Project Files, there’s no C++ code in it so there’s nothing for it to generate.

It’s worth a try. I’ve had to rebuild from scratch on the same PC before. If you’re not at the PC where it works, you can just delete the directories that arent Source/Content/Config. Obviously you need the uproject file, and if you have a Pugins dir, just go through the plugins and delete the Intermediate and Binaries folders.

Thanks for the suggestion. But I think my project is just the regular version without any C++ code, so when I right click on the project and try to generate project files, it simply tells me there’s no source code.

OK there’s no C++. So don’t generate project files. Just rebuild it from scratch. The point is to get rid of the intermediate stuff. There is a diagnostic question that needs to be answered. It’s like checking an extension cord by plugging your device directly into the wall.

Gotcha. To clarify, when you say rebuild it from scratch, are you saying to create a new project and simply migrate stuff over? That’s the way I’m usually familiar with unless there’s another I’m not aware of.

Thanks again!

No. Just delete the Binaries/Intermediate/Saved directories in the main project directory and in any plugin subdirectories. You only want Config/Content/Source and plugin data that isn’t generated (usually just need to delete Binaries and Intermediate in those). Once it’s clean, try it out normally.

Understood. Deleted those 2 folders and launched the project and still crashes.

Here’s an updated log but don’t know if it would be of any help.

link text

I forgot. You also need to delete the DerivedDataCache directory. Did you do that?

Yup deleted that as well. As much as I hoped that would work, it didn’t do the trick unfortunately.

Oh lord… OK two more diagnostics:

  1. If you haven’t already, on the destination machine, create a new template project, close and reopen. You want to be sure this is a problem with your project and not a general issue.

  2. This cleaned up project directory – zip that up and try it on the PC where you know this project worked.

If it isn’t a general issue on the destination machine and the project can go back the other way then the only thing I can think of is that something isn’t installed in the same place and UE4 can’t find it. In that case, I suggest uninstalling everything (UE4, VS, SDKs, etc) and reinstalling them making sure they are in the same path that they are on the origin machine. You might also want to play dumb and follow Epics installation directions step-by-step just in case one of your potential assumptions was wrong when originally installing everything.

Sorry. I was really hoping that it was the intermediate files…