Project crash at 70% while loading project

Hi UE4 engineer and developer,

We got serious crashes while we were opening our game project. It crashes at 70% without any reason. However, it happened after we successfully compiled our source code into the engine by loading blueprint by our source code.

We try to solve the incident by ourselves, and we research a lot and seems like other developer meet the same problem. We have tried rolling back our source code as well, but apparently the source code we made doesn’t show up in the content browser. We really concern about it that it will be happened in the future because it’s going to directly affect to our production timeline.

We really want to use this engine because it really elevate our productivity and production value in art and design.
Anyway, thank you in advance and please help us find the solution in this issue as soon as possible because we’re already in the pre-production process.

Best regards,

Maythee Chauypoo | Lead Game Designer | mchauypoo@gmail.com

Hi. This has happened to me as well… turns out that its always something wrong with my code…Even when the code compiles I’ll still get a crash. Not saying your code is wrong, just telling you my experience.

Wow, thanks.

And May I ask the way to prevent the crashes? Or should I backup the project file every time I compile the source code?

Are you able to open your project in Visual Studio and then run it through there? The crash should help you find where the error is in that case as it should break on the place it fails.

have you packed a project and looked at the Error Log?

Yep I can run the project in Visual Studio, but couldn’t run it in there though. Apparently, it seems UE4editor.dll is the cause of this issue. I was trying to create a new project and replace it into the old project and it works surprisingly.

Every time I had this issue was because of some reference in a BP that got broken, for example I deleted a class that was used as a parent by one of my blueprints. Revert a couple of revisions in your project and check if it opens the editor from source, then track down what BP or classes have been added to track down the issue. Good luck!