Product Viewer 'Explode' tool implementation and function

So after digging around on the web and in the product viewer project, I found the Explode tool script in there but I’ve not been able to work out a way to make this work in the product viewer, nor have I found an easy to understand, straightforward answer anywhere. It’s not mentioned in the Documentation of the project itself (https://docs.unrealengine.com/en-us/…Product-Viewer)

If anyone has any idea how to get this to function, it would be most appreciated.

Thanks in advance.

HI GSS_JXB,

Select all the Static Mesh actors in the level that you want to Explode
**Convert the selected Static Mesh to BluePrint **

** Create Blueprint **

create2.jpg

Open newly created Blueprint
Inside Blueprint , select class setting
Find Class Options in the right panel
Change the Parent Class to Explode_BP

explodClass.png

In the Event Graph , right click on event begin play.
Add call to parent function.

parent.png

Animation Setup Select your Converted BluePrint In the World Outliner Tab
Look in the Detail Tab, in the Default Category section
All Those Button Will be used to setup Your Explode Actor

**Press Get Components Button **
Set initial Transform
Press Set Initial Transform Button
The First Transform Array Will be Filled with desired elements

Select the Components In Your Explode Actor From the Detail Panel and Move Component to desired location
Press Set exploded Transform button
**Move the Explode Actor Under the Interactive Root
You should be good to go :slight_smile:

Let me know if you have anymore questions.

cheers**

hello marie claude, I can not get out " **Add call to parent function." **where is it?
thank you so much

Under the right click menu:

thank you so much

thank you so much!

the explosion works, but when the blueprint is created the pieces are no longer positioned as they are original and the scaling is also different.
I tried to put the coordinates as they are leaving but it does not work.
is there a way to start the explosion with the pieces already positioned where they are starting?

after creating the blueprint, before giving it the positions of the exhibit.
How can I put them back where I’m at the beginning?
I attach image

why from this error if I save and close?
video error: explode - YouTube

I got this working somewhat, and managed to record a shot clip in preview mode:

However when I saved the project and restarted the editor, the positions weren’t saved and nothing worked anymore. Is this something that’s supposed to work right now? Also when I tried packaging the project, it was successful but the exploding doesn’t work at all.

Edit: Upon further investigation I noticed it’s the mesh components that are not saving, transforms are.
Edit 2: As far as I understood form studying the blueprints with my very limited experience, this isn’t a finished blueprint and it simply can’t work as the object references aren’t saved anywhere permanently. I worked around this by saving them in a string array and using that to rebuild the object reference array on load and demand. Works fine like that when packaged too.

congratulations beautiful model.
We await answers from someone who understands

no one knows how to solve the problem of positioning and saving?

I don’t know what to do about the initial positioning changing when you convert the parts to a blueprint, but I worked around the saving by storing the components in a string array instead, then using that to make the object references on load. Probably easier and better ways to do it, I’m only a beginner with all this.

HI there,

Sorry for the late reply.
I’ve looked at the issue with the Save.
I was able to reproduce it :frowning:
It is clearly a bug on our side.

Here’s the problem:
The Explode Transform and the initial transform Variable inside the Explode_BP_Actor are set to hidden.

Visible.png

If you make them visible it should fix the problem of the save not saving anything.
Having said that, you will unfortunately have to reset all your initial and all explode transform.
We are actively working on improving the template and fixing it.

thank you

Thanks for the reply!

And oh wow… if it really was just that I feel extra stupid as I mostly ignored that whole blueprint as I first didn’t understand it’s purpose, I did check this exact thing on the Explode_BP blueprint only. My work around isn’t working in larger scenes so this would be welcome fix indeed :slight_smile:

Other than that I’ve been adding my own features to this template including multiplayer spectator mode and sort of a cross section tool. I foresee a lot of use for this if I can get it to work like I want.

Also another buggy feature I noticed was the World Scale setting, the way it is right now feels like it’s disabled on purpose though as the control widget for it is basically upside down and thus not visible without editing the rotation in the blueprint, and after getting it visible the scaling itself doesn’t work correctly and only scales the view (pawn?) and controller meshes but not the actual controls which obviously makes this feature unusable.

Okay I got a chance to try this now, and it did not fully fix the issue: packaged project still doesn’t work. But then I remembered something I spotted before:

explode_bp.png
This node being disconnected in the Explode_BP construction script. I connected that and added Call to parent on the construction script from the blueprint made for the parts themselves and then it worked on the packaged project too.

However this won’t fix the problem when reloading the project in the editor, I have to use the “Get components” on each explodable part each time I load the project in the editor to restore functionality. I’ll be testing more tomorrow and try to apply this to my project and see if anything else comes up.

Edit: Scratch all this, figured it out as laid out in post below.

Okay I finally figured this out to my satisfaction:

  • The Explode_BP_Actor blueprint is redundant like I initially thought, probably a leftover from early version or something. Deleting the whole thing had no effect on anything and it wasn’t referenced anywhere.
  • As the Explode_BP blueprint is using hard object references for the meshes, it will reset each time when reloading the project and wouldn’t carry out to the packaged build either. To fix this I changed the hard references to soft ones instead. As I’m a beginner I really don’t know why this wasn’t done in the first place, there’s probably some drawback to this method (performance?) but I haven’t noticed anything yet. Here’s what I did:


And then obviously replacing the mesh references in the other events to this new soft object reference as well. After these changes everything works like I want it to, everything is saved when reloading the project and it also works in packaged builds perfectly.

Here’s an example of it in action with 3 spectator clients added as well:
https://streamable.com/app6u

Looks really good. Question, I noticed your objects move back to their original position much smoother than the default ones I’m using. What did you change to get that? Cheers!

I added linear interpolation to the movement in the “RestoreInitialTransform” -custom event in “ProductViewer_Base_Pawn” -blueprint. It’s too messy a solution right now to share though, and unfinished in regard to how it works in VR (need to add rotation as well).

The Explode Tool didn´t work for me! Tryed evertything Marie-Claude said! Is there no step by step tutorial or video-tutorial? This was nice to have! Fixes or updates available?

Either those instructions were always incorrect or became outdated with the release of 4.21 so they wouldn’t really work, but if you look here: Collab Viewer Templates in Unreal Engine | Unreal Engine 5.3 Documentation

And scroll down, there are now different instructions for the explode feature that should work better. I figured my own solution that works fine but probably better to go with the official one.