Procedural Foliage spawning not working on landscape layer

Hi,

I am trying to use the procedural foliage spawning but for some reason it is not spawning anything on the landscape. It does however spawn trees on top of building etc but it will not spawn on the landscape at all.

Any help would be greatly appreciated.

Thank you

Hello Muffinlasher,

Following the tutorial in the following link I created a test. This test involved spawning two meshes within the procedural foliage spawner. I am able to see my meshes that I added to the spawner on a landscape.

Are there any steps that you have taken that are different than the ones in the tutorial? Are you resimulating after you make any adjustments to the spawner?

Hi ,

Thank you for your reply

I have followed pretty much the exact same steps as you did in the video. I do re simulate when I make any changes but it still doesn’t spawn anything on the landscape layer itself. If I add static meshes into the scene it does spawn on top of these just not on any of my land scape.

Thanks again

Louis

Interesting. Would you provide screenshots illustrating your foliage spawner only drawing on static meshes along with your DxDiag (Computer Spec’s).

Hi yes, please find attached two images in the engine showing the spawning only spawning trees on top of the house/box and not on the terrain.

Louis

Thank you for providing the screenshots. I will continue to investigate this issue.

I have been unable to reproduce this issue on any of our machines. Your computer is more than capable of handling our software and developing with it.

Does this happen in a new clean project or just this one? If not this could be a project specific issue.

I’m having the exact same issue. Procedural foliage not spawning on landscape layers, but will spawn on mesh. Landscape rotation is set to 0,0,0. I know that’s been an issue in the past. When I remove the layer requirement, foliage spawns in just fine.

Wow, thank you so much! I was having a similar problem to the OP and your suggestion of setting the landscape rotation to 0/0/0 solved the problem. The procedural foliage spawner now works correctly!

Did you make sure that you have landscape enabled in your procedural foliage volume?

300076-proceduralfoliagevolumesettings.png

I’m having this issue as well. For whatever reason the foliage refuses to spawn on my landscape. Unfortunately, my landscape is not rotated so that’s not the solution for me. I noticed someone said when they remove the layer requirement it spawns… what’s the layer requirement?

Oh, I figured out the issue. I was using some Foliage Type actors from a marketplace asset that had been configured to only spawn on a specific landscape material and because my landscape was using a different material, they wouldn’t spawn. If you open up the Foliage Types (static mesh foliage) that you’re using in the spawner, you’ll see a drop down for Inclusion Landscape layers. Either add your landscape to the list, or delete the array by clicking on the trash can icon, and it will spawn on your landscape.

4 Likes

You are a great man! thanks for posting the solution!

1 Like