Problems with two-sided translucent objects?

I’m having problems with making translucent and alpha composite materials two-sided. One sided, they look great, but with two sided they look terrible.Do you know how to fix this??

One sided:

One sided in material editor:

Two sided in material editor:

Two sided:

Even games in the early 1990s were able to have two sided translucent objects but in Unreal Engine it causes gltiches? What gives? I googled this and apparently I’m not the only one with this problem. What can I change to get rid of these glitches?

Edit: I added screenshots from my project to give you an idea of the problem


You would need to sort polygons from back to front to avoid this problem.

In 90’s all the polygons were sorted but it’s not feasible anymore because polycounts are 1000times higher.

How would I go about doing this? Or is just not possible in Unreal?

I don’t think gems/faceted objects don’t have that many polygons

I would do it by dublicating gem mesh. Disable two sided rendering from material. Then enable “Reverse Culling” from second mesh. Then set sorting priority so that second mesh is rendered first.

Okay, thanks a lot.