Download

Problems With The Swarm

Hi All,

Not too sure if this is the best place to post this, but its the most relevant forum I can find as it deals with the lighting! I’m having some trouble setting up the swarm for UE4 so I can build my lighting across multiple PC’s

I’ve got SwarmAgent running on a bunch of PC’s, SwarmCoordinater on a seperate PC managing them all. It can see all of the PC’s I want, all the Pc’s can see it.

When I try to build my lighting, the coordinator will light up saying it has assigned them, and to the correct PC, but nothing inside the Agent dialog on the PC building indicates it has got them helping it out, it stays on just a single PC.

Has anyone encountered this before/fixed it before?

Thanks :slight_smile:

Every once in a while we have some computers that are bad sports in general, but there is one major thing to check on. I keep finding that Swarm gives itself the wrong firewall settings. Open your firewall settings, go to where you allow apps to come through the firewall, and make sure that Swarm and UE are allowed on Private networks. Sometimes they get stuck to only allow on Public networks for some reason. That is the easiest fix we’ve found.

Hmmm, checked that and it wasn’t this.

I downloaded the blueprint tutorial from the engine itself, and that is actually seeing and connecting to everything in the swarm. I go back to my actual project, and nothing!

-Make sure that Swarm is allowed through the firewall
-Make sure that the clients have the Swarm Coordinator machine set as their CoordinatorRemotingHost
-Make sure that the clients have the ‘AllowedRemoteAgentNames’ and ‘AllowedRemoteAgentGroup’ settings set to Default and * respectively (I like to set the AgentGroup to Default just because it works for me, and the Agent Name as a wildcard ‘*’ just works)
-try to ‘ping’ the host from each of the clients to see if they all respond correctly.
-ping the clients from the host to make sure too
it should work if you’ve set it all up correctly.
The only thing that I can see that could mess it up if everything is responding, is if the Firewall is blocking it or if the client machines have some software on them that makes Swarm think they are in use (but they should still show up when you go to do a build, just with ‘waiting for agent to become available’ instead)
Can you post a picture with the settings you got on the host and clients, as well as what you see when you go to build?

Yep tried all that.

If i open up the blueprint project, made by Epic, the swarm all pops up and works.

If i open up my project, based on the FPS template. the swarm is a no go.