Download

Problems with lighting / shadows

Hi guys.
There is a problem when building light, namely, at the junction of the two objects have a clear border. Tell me, please, how you can get rid of it?

Shades of different shadow.
974ee53773.png
79ca89b507.png
11319e82d3.png

BSP test
4ff5405597.png

I would adjust your lightmap resolution. Then play with the AO settings. This doc is pretty much my go to on lighting

https://docs.unrealengine.com/latest/INT/Engine/Rendering/LightingAndShadows/Lightmass/index.html

lightmap resolution = 256
change the resolution of the problem has not disappeared

Hey NetGon, I recommend you to check out Lighting Troubleshooting Guide in future, it’s pretty helpful!
About current issue - I’m not sure what exactly it is, but could be this bug

EDIT: I’ve found this thread, Tim Hobson posts in particular. It’s basically a little guide how to fix issues mentioned by you

I’ve not had the time lately to get the Modular seams and color differences portion of the Wiki Lighting guide done. That and Lightmass troubleshooting are my next two big ones to get done. Unfortunately, they also will take a little longer than some of the other simple setups. These two topics come up very often and I want to have plenty of examples to go through what works and what doesn’t.

You should be able to reduce this effect by adjusting the World Setting > Lightmass options for

Indirect Lighting Quality: use 2 or higher. This will definitely increase any static light builds though.
Indirect Lighting Smoothness: This will need to be tweaked but starting around 0.75 and lowering down to ~0.6 in that range should help a little.

Other factors will include lightmap UVs as well along with lightmap resolution.

For now the forum thread that zeOrb linked is the most in-depth helpful place to start.

Yes, it works, but in some places there is a difference.
Thanks.
20b5b3d5a4.png

Only here for some reason in your test project does not work.
https://forums.unrealengine.com/showthread.php?46269-Modular-Asset-Lighting-Problem&p=155539&viewfull=1#post155539
c64ad9fd2d.jpg

The effect will be more visible when it has more indirect lighting. You need to avoid constructing objects that way as much as possible. Besides the lighting issues it’s not actually efficient to do it that way anyways.

Hi.
Which is why this can happen?
Some sites StaticMesh blacken.
b6a4f26e45.png

Interesting pattern.
This (seams) occurs on any default project (even on high settings):
This BSP
UE 4.7.3 version
83ce7917d2972d60666ea36701d60bf0b3f48184.jpeg

This turns on the project created in an earlier version of UE 4.5, that is, the project was converted to 4.7, but the problems with the “seams” no
LM default settings.
d838daedef.jpg

It is not clear how to get rid of this problem, but to a previously created project to collect a new project…

Although there is also not working. Rushed to conclusions.
Trouble…

With BSP issue has been resolved. It is important to simulate the precise grid.