Download

Problems with "in editor" and "as standalone"

Hello my dear friends in worries,

I have a Problem, as you can guess. When I start my project through the editor (VR Preview), I get this result:

0fef85e79dd562189e1c1079ba07dd02fe43ce40.jpeg

For the explanation, I use this function

to get the chaperone coordinates. I place a cylinder at that position, it is just for
debugging and orientation. Also, I positioning the large frame (with the wooden
floor on the left) to the chaperone border.

Everything works as I expected it to.

When I pack that into a standalone client for testing on a different PC, I get this result:

There are no cylinders for the chaperone border and the position of the wall is wrong.
You can see it, the wall is inside of one of the light sources…

I tried inside the game mode “Enable HMD” and “stereo on” as console command:

I also tried to start the client with -vr and/or -fullscreen, nothing works. The “game”
itself works normal (i.e. motion controller and basic game play) but the chaperone
borders are not present. I also tried to restart SteamVR and the whole PC, but nothing
works.

Does anyone know how to solve this? :smiley:

Thanks in advance and with best regards,

Alex

Did you ever solve this problem? I’m having the same issue when using Get Bounds from the chaperone and cannot figure it out.

I used the VR Template with only minor modifications (to the hand mesh position) and the vive chaperone border (displayed when teleporting) shows up fine in the editor but is missing once built as standalone client.

-st