Download

Problems I've encountered while working on a cinematic

Recently, I have finished working on a remake of the Matinee Fight Scene (Matinee Fight Scene Remake in Sequencer)

During my work I bumped into a multitude of problems ranging from minor annoyances to roadblocks that took me many hours to overcome. These were mainly happening in Sequencer, but I had problems when using other UE tools as well. Below I have compiled a list of issues that I have noted during my work.

Unfortunately, currently I don’t have the time to go into detail of every issue, but if asked to I’m ready to explain some points further.

I would be curious to know if there are good workarounds for these issues or if you are aware that the issue is being worked on. I wonder if I have missed something, or if these really are bugs/limitations. Finding solutions to these problems would make the working with sequencer workflow way more enjoyable.

Sequencer
No shortcuts for solo/mute track
No indicator as to which tracks are solo’d and which are muted
Can’t solo a track in a muted folder
Audio fade handles too small
Can’t disable/enable fade for multiple items at once
Audio track playback doesn’t align with audio waves representation when using time dilation
Cine camera focus tracking doesn’t track object’s location during animation (it tracks the object transform, which for the characters in the fight scene is static)
You have to click on camera item in sequencer to add keyframe with s
You have to click on the viewport for ctrl+shift+p (pilot camera) to work
Spacebar doesn’t play unless clicked on sequencer (annoying when setting up cameras)
Right/left arrow changes function depending on which item was clicked in sequencer (e.g. when clicking on folder structure it expands/collapses categories)
Moving cinematic camera cuts fills out the space before and after the clip
When scrubbing backwards, cine camera shots play instead of normal cameras (which are in the camera cuts layer above cine cameras). When playing forwards, it works as intended
Transform keyframes disappear when expanding section (exposing x, y, z transforms)
Key icons sometimes don’t change (constant keyframe stays round)
Attaching camera to knife makes the camera spin (scene from the latter half of the video) - no workaround apart from manual animation
Audio breaks/pops on 1.0 time dilation (1.01 fixes it)
No keyframe available for cinematic camera focus method

Animation Window
FPS between sequencer and animation additive track don’t line up
Sequencer and animation window - animations are different
Can’t go to next/previous keyframe in animation editor
Applying additive animation takes several minutes and locks the engine (when working with the guy in the white suit. Brown suits worked fine needed only a few seconds when applying)

Sequencer Movie Rendering
Video rendering window is cropped on high resolutions
Audio export still experimental - and doesn’t work properly
Sequencer doesn’t render all frames (e.g. the last frame in folder is 3080 instead of 3015. I’ve made sure the end frame is set correctly both in sequencer and in the render out movie dialog)

Movie Render Queue
Movie render queue needs cine camera shots to have underneath camera actors for camera actors shots to render. And then it still sometimes decides to render cine cameras, even if they’re below in the camera cuts hierarchy
Audio artifacts when using render queue (I think it happens during cuts)
In the end I had to use my computer’s stereo mix in the end to record audio, which almost always produced a pop at one place in the video, but I was able to edit that out in “post”

One other important thing I forgot to mention:

In order for the “turn Matinee into Sequence” function to work for a modified Matinee sample project, I had to use UE 4.23.1. Using the function in 4.26.2 made the engine crash. Thankfully, after turning Matinee into Sequence in 4.23.1 I could start editing the project in 4.26.2