Problems getting height blended landscape layers to work


I am pretty new to Unreal Engine 4, coming from 4 years of using Unity, so I am pretty sure I am doing something terribly wrong…

I have successfully set up my landscape material with weight blended layers after some work (I am puzzled there even this takes so much time to setup, but alas, I guess thats just the unreal way of doing everything node based)…

Now I am trying to switch from weight blended layers to height blended layers, but cannot get it to work no matter what I try. Read all the documentation and followed all the guidelines, still fighting with this material not working correctly.

I currently am using 3 layers with color, roughness and normal map each. Layer 0 was set to alpha blended as per the documentation, the other 2 are set to height blended.

I created a “weight blended layerInfo” object for all the layers. Painted the map all with layer 0 just to get a value in. Then I tried to apply one additional layer, seems to work fine (even though it isn’t really height blended… I guess the alphablended layer will never heightblend with any other layer?).

As soon as I add the third layer in the same section, things start to fall apart. Layer 0 (Alphablended) turns black for that section, and the other layers now do not blend at all, no heightblending or weightblending, just a hard seam.

Example Images:


Problem before applying second layer to second section


Problem after applying second layer to second section

My questions:

1) what exactly does the alpha blended layer do? Does it just fill in the parts where no other layers are applied? What is the difference to a weight blended layer? How does it blend with a heightblended layer?

2) what could be the problem stopping my material from working when more than the alphablend layer and one heightblend layer are applied to the same section?

3) Is there a way to fill the whole landscape with one of the layers so you do not have to go and paint everything with the painfully small brush all over again as soon as you twesk the material and change the layerInfo?

thanks a lot for any help. I feel totally lost here…

Found the Solution myself after watching one of the tutorial vids again.

I used b+w heightmaps as height inputs in the layer blend nodes. In the tutorial the alpha channel of the normal maps was used.
So I also plugged the alpha channel of my normal maps into the height input and it worked. I am quite confused right now, but I guess I need to go and check what the unreal engine exactly does with the alpha channel after the import of the normal map.

I made another mistake as it seems the alpha blended base layer cannot be used for painting.

Works now for me.

Same Problem. Your solution do fix some issues!
I plugged in the alpha from normal, applied, save.
Then repeating plugging the rgba in to material normal. That do fix it also for the others, like Roughness! Plug in, save, plugged back, save.
No clue, if this is a bug, and if that was fixed with newest Version. I still use UE 4.9.2