Problem with widget interaction

I have a problem about using widget interaction.
I pawn a character “A” and add widget interaction to it in blueprint.
“A” could interact with 3D widget well.
Then I destroy it and pawn another character “B”, add widget interaction to it in blueprint as well.
But “B” could not interact with 3D widget.
Anyone know why??

wacth Victor Burgos tutorial, he explains in detail… has to do with giving pointer (WI) unique index number… if ya don’t get it fixed holler back, I’ll detail for ya when I get my monitor working this weekend, hopefully. (bulb)

Thank you for your reply.
But my English is not good enough to understand it.
I post 2 screenshots to let you see if I am right.

1.How I attach widget interaction component

2.My keyboard actor to interact with

real quick, and since i do not have a vive i use GearVr and have single trace out, but have encountered this with more than one player in scene. I see on the first pic, there is a Add Widget Interaction Component, and set a different number for each hand controller on the Virtual User Index, and if you do mean like player one, and player two, each with two controllers… be sure to make each controller have a different number, (player# - controller) P-1 L1 R2, P-2 L3 R4 etc…

EDIT ok on second thought… if that does not work… above… try for each player setting the Virtual user index on Left Right controller to same number, and then one each controller setting the pointer index to 1 on right and 2 on left, and for player 2, VPI -2, L-PI-3, and R-PI-4.

Also it looks like you might want to make sure enable hit testing and auto activate are enabled on each widget interaction you have. Hope it helps a bit… wish I had a Vive to walk ya thru it. Be sure to study the basic template set up and its controller BP’s might give ya some clues as well that get unmentioned by some.


Readdress this issue with a VIVE tag heading in options so it can get a narrowed target audience and ya might get better replies…

Thanks man, but I use another way to fix it.
I create a WidgetInteractionActor, and attach it to controller.
When I need to destroy the controller, I detach it and reattach it to the new controller.
It works.

You need to uncheck the Consume Input for your input event trigger. Select it in the Event Graph and go to the details panel. Whichever controller spawns first will be hogging all the input.