Download

Problem with Unreal Engine -> Build -> Artifact

Hi all !

I’ve 2 issues with Unreal engine 4.

First, I’ve a very ugly artefacts on my mesh :
b39800988106102c34452ba2cde6c356b679ca09.jpeg
e9435f1ed1a45c79da0d6824b54e5823e5061c49.jpeg

I tried to increase Lightmap (very similar result with 128-512-1024-2048 ), and increase the World Setting. It’s better, but I’ve still this artefact.

Second, I’ve very strange constrast problem. I need to cut my Floor in 2 parts, so I exported Floor_Right, and Floor_Left. I unwrapped UVs, I created a second chanel for light map. My 2 Statics mesh are exactly same ( exept first is Right, second is Left part ) but when I build, I’ve this result :

a271ba0c1a5466c79f15009b9daa31b2cee5b096.jpeg
3a932470f1ed887a5c0a76fbd70aa4ffc4c13563.jpeg

how can I resolve this problems ? Do you have an idea ?

Thank for all

Alec

Unless you really have to, you should keep your floor as one mesh.

Other than that, try messing around with lightmass settings. Increasing lightmap resolution might help.
Apparently there are some lightmass settings you can change to get rid of the artifacts but can’t remember what they are. Or, just use dynamic lights :slight_smile:

Hum, yep, I need really my floor in 2 parts. Isn’t possible ?

why dynamics light ?

ok i ll try to change lightmass setting, thanks !

First thing is that all of your UV’s MUST be within 0 > 1 space in your lightmap channel (the checkered area), otherwise you’ll get overlapping errors. Each polygon on your object needs to have it’s own space in the UV map in order for a proper lightmap to be baked. Simplest way is to create a second UV channel with another UVW Unwrap modifier (set the channel to 2), then select all faces -> Flatten Mapping -> Pack UV’s.

If you want to, you can avoid that last step and the Engine will attempt to generate UV’s for you in the second channel. (UV 1)

Dynamic lights probably won’t be useful for you, since this looks as though it’s going to be an ArchViz world of some kind.

These are unfortunately just some Caveats of the Lightmass system, but no stranger to static lighting systems in general. Tim Hobson made a huge and very useful thread somewhere since this question has been asked a number of times… I’ll try to find it but in the meantime if you search the Wiki, you should be able to find it!

I’d like to see this improved in the future since it’s probably the biggest question asked about lightmass next to the infamous ‘Overlapping UV’s’ questions. Perhaps point-sampling of light maps around mesh seams and averaging the results. Dunno…

Thanks for this answer =)

Uvs of the channel 0 are outside of the uv square, but it s necessary if I want tiles my texture.
But the Channel 1 is inside of the uv square :

the world Setting are good :

and my mesh setting too :

but the result is still dirty :

I can’t set 4096 for lightmap, the build is really tooooo long :confused:

I don’t have overlapping issue.

I don’t understand, I bought London Scene ( UE4 archviz ), it’s same world setting, same unfold uv ( flatten ), and with 512 lightmap resolution, he has a better result than me with 2048…
why ? :confused:

What about increasing the distance between the UV islands?

Just to be sure: Are you building the lighting with production settings and not preview?

Except for the floor (iirc there was the exact similar issue somewhere in another thread, check out the ArchViz forums) is shadow bleeding from too little space between UV islands as well as not so great unwrapping for lightmaps.

Solution:

Use higher spacing, you dont need to care too much about stretching in the lightmap UV channel
Stich UVs where roughly the same amount of light falls onto the model (for static lighting)
Split UVs where a entirely dark poly will hit a bright one (such as unseen backsides of objects) Works great for walls and the like, for more complex objects you want to look out where to put the seams.

  • or remove unnecessary polys

read this for a summary on lightmap UVs:

Hi all,

**@Joinmake : **yep, I m in Production mode :slight_smile:

@Bogieman987 : usually, I do a default Flatten Mapping ( spacing 0,02 )

@Haldolium : I tried to use 0,04 and 0,06 for Spacing, it’s slightly better, but still not clean :confused:

Hum the flatten mapping split already the uv’s no ? my wall is in 6 parts ( front, back, and sides ), I can’t split more ?!

It’s the result with higher spacing :

I tried to stitch my uv when it’s dirty, but still bad result…

For to illustrate my example, i can show you the London Scene ( UE4 archviz )

Just a simple wall, 2048 lightmap, like me, nothing special in uv :

but the result is absolutely better :

How explain this ?

Hi all

I tried new technique, i changed my wall meshes, and I stitched my uv, like this :

307bfb049ed51c211a00b7809c9c8d09c6e7cc66.jpeg

the result is better, but still not perfect :

any ideas ?

I would change the lightmass settings. Scale back to 1 and smoothness to 0.65. See if it helps.

Up :confused:

I tried to scale back 1 / smoothness 0, it’s different, but still ugly :confused:

  • I tried to upgrade lightmap in the meshes
  • I tried to make a second lightmap chanel in 3DS ( and I disable Generate Lightmap UVs in UE4 )
  • I tried to modify values of World setting
  • I tried to modeling/export my wall with another way ( you can the new technique in my previously post )
  • I tried to stitch the UV wall

And it’s still fuc***g ugly :confused:

If somebody have a solution…

It’s been a while! But did you manage to solve it?

Hello Alec, how are you? I came across your help page or asked for help for problems with shadows on your meshes. I wanted to know if since the time you had found the solution, because I exactly did like you, I bought an Archviz scene to learn, but I have exactly the same worries as you and I look for me Does not find any where to come …

So I hoped that maybe you could help me :slight_smile:

Hope you have the answer to my problems.

And sorry for my english i’m french.