Download

Problem with transparent material

Hi!
I’m new to Unreal and I’m trying to get a hang of material setup.
I’ve been searching high and low all over the Internet for a solution so I’m hoping someone here can help me.

I’ve got an object that should be partly transparent, and a simple sharp mask wont do since the transparency shouldn’t be 100%.
I want it to have a dirty, “half-see-through” look…if you know what I mean.
This is the Object with the texture and normal map:

Problem is when changing the material blend mode from Opaque to Translucent and adding a transparency map (alpha or BW doesn’t seem to matter)
I loose all other material settings and ending up with this result:

I’ve been ******** around with the UE material settings and have about 10 different transparency maps with different settings but without any luck.
The closest I’ve gotten is when setting the blend mode to masked, but then I get the sharp 1 or 0 opacity value.

Very thankful for any help or suggestions!

From what I understand, translucency is pretty limited due to deferred rendering.

The only way I can think of is using layered materials, or perhaps separating the meshes altogether and then applying the appropriate material.
There may be issues regarding the translucency, I tried mixing translucency and opaque materials, had issues with the translucent parts appearing in-front of other parts. Eventually gave up and went with masked and opaque.

The problem seems to be that you’re losing your reflective properties when you use translucent materials. Since 4.8, this can be fixed by activating Screen Space Reflections on your material. It’s in the Translucency section in the Details of your material. It’s also usually a good idea to activate Responsive AA when you do this, and you also need to change Lighting Mode in the same section to Surface PerPixel. I think this will fix your problem.

Thanks for your replies!
Didn’t see em’ until now due to the email notification didn’t go through.
Screen Space Reflections, SPP and res. AA didn’t seem to do anything though :confused:
Been playing around with the settings for…probably hours.
I’ve managed to get a soft, translucent look from dirty to clear glass with reflections (though be it the reflections are extremely weak), but still no specular what so ever.
So I’ve pretty much given up and decided to wait until UE fixes a good and easy glass shader.

What really annoyed me was that when creating decals with soft transparency, it works just fine with trans, spec, normal, reflect… wtf?!