Problem with tracing objects

I have got a problem with tracing in blueprint in that whenever I trace something I get no results whatsoever.

In the example, I have set up a staticmeshactor to do a spheretrace. No matter what objects I set for detection, it won’t return a true. I have double checked the actor’s object responses and it has been set to BlockAll, so as far as I know, I should at least get it to return a true on itself. I have also tried a trace by channel, but it’s the exact same result. Nothing.

Since I am trying to do the behavior tree tutorial, I really need these traces to work. At the moment, I cannot get that tutorial to work either since, again, no matter what I do the traces simply return nothing.

Well you are using the same location for both the start and end of a trace… The trace algorithm probably bugs out as the trace length is 0.

Jup, that was it. I didn’t know that even though it was a sphere trace, it still needed those two positions to be different. I though that as long as the range was not 0, I would be good to go.

In which case maybe you could accept my answer to make it green and flag this question as answered. Thanks.

Ah sorry! Yeah, of course. Thought I had done so already.