Problem with toggling/setting visibility

Hi, I am trying to show or hide different 3D GUIs on the press of a button (and later through events when reaching a specific phase in the application).
I am using the first person template with my own content.
I have setup my UI (which is just supposed to display text, no interaction) with UMG and added it as a 3D widget to my character. The application is supposed to run in an Oculus, I know this is not the best way to do this, but for now, it works for me.

Now I am trying to toggle the visibility of my UI with the press of a button. Unfortunately, nothing happens, I’ve tried different ways and went through different other examples here, no luck.

Here are a view screenshots:


I’ve set this up in “MyCharacter” blueprint, since the UIs are attached as components to the player. Didn’t work. Tried doing the same in Level Blueprint, didn’t work

I’ve tried a different version using “Set visibility” instead of toggle, didn’t work…

I’m really out of ideas… Please help!

I have the same problem at another spot too:

I have a component blueprint for a sphere with a surrounding collision sphere. I have in total 6 of those spheres in my scene. The spheres change their material on collision start and back to original material on collision end. This works fine, but I would like the user to be able to see the collision shape in-game. Which works fine too, just turned on the visibility in the components view of my blueprint. Now, I would like the user to be able to toggle the visibility of the collision shape. I have tried setting it up in the level blueprint and inside my sphere blueprint with no success.


I just don’t get it, why toggling won’t work for me :frowning: I must be missing something in the setup process or something…

Is “Control Info Char” actually a SceneComponent? As in, you found this node in the list and then wired the target into it. I bet if you pulled a wire off of your UMG widget component and typed “Set Hidden In Game” you’ll find the right node that works.

Try checking the “Propagate to Children” option on the visibility or hide nodes. I was having the same problem and found that that worked for me, both for “Set Visibility” and “Set Hidden in Game.”