Problem with textures!

Hello! I’ve imported a texture onto UE4 (2048x 2048) and I see it pixelated. I’ve tried to set mipmaps to off, but still the same. Although when I press “defer compression” and I make ANY change, the image gets softer and looks exactly like how I want it. How can I make it stay that way? here are some images

Here its the image : notice the pixelated edges

Heres when I press defer compression and make ANY change. I can change any setting, and then the image converts to this version :

How can I make the texture keep that blurred/ softer edge?

Please, help! : (

Can you share your texture so we could check it on our own?

My best bet would be that you imported your texture from a PNG or JPEG file. Have you tried exporting it as a TGA file from your image authoring software? I had this issue in the past and I’ve been exporting as TGA since then.