Problem with testing/opening HTML5 packed project

Hi there, I create a simply web game. (I use UE4.9 p4) After Packaging I tried open .html file using few browsers, all of them show:


I have tried reduce HEAP but it still not working, my game also is on the server, but it’s the same problem. I don’t know what I can do. I have checked a lot of posts on answerhub, but none of them helped. So I decided show you my story :wink: Also if I launch my game using Chrome(64b)/Firefox in testing version i see black screen, only using it works. This game is really early version, but it is on the server, lets check this: [Game][3] (p6) is the best of all.

Hi Inv,
I’m having the same issue my end as well with 4.9p4.

Lucky guy :smiley: So I’ll wait for new preview.

Same problem here with Tappy Chicken running on UE 4.9.0 final release.

I thought release 4.9 will fix this, unfortunately not. I created a very basic test project development/shipping and testing local machine, I got same error as [InvisibleJoke]. Will keep on trying few things and see.

Hey InvisibleJoke,

Since you’re on Preview 4, I’m assuming that you’ve obtained the Editor from the Epic Games Launcher? If so, have you upgraded to the release of 4.9 yet? If you have, could you please attempt to package your HTML5 game and let me know which browser it’ll work on. Also are you able to launch from the Editor onto , FireFox or ? Do they work?

Please provide me with additional information in order to further assist you, thanks! :slight_smile:

I haven’t upgraded to 4.9 yet. I’m still working on preview 4. Already I’m away from the computer which is running. On Friday/Saturday I’ll answer you if it works. Of course if I’ve available update to full 4.9 relase. I checked today morning if I have update to 4.9 release but it wasn’t.


UE 4.9 didn’t release until around 9am EST this morning, that’s likely why you didn’t have it available. But please do contact us when you’re able to test this on 4.9 and let us know how it goes.


Hi ,
I got exactly the same issue as InvisibleJoke, in 4.9 release. I’m able to launch
Firefox, chrome, in the Editor, but got error when testing development/shipping outside the editor see attached screen shot.alt text

In Editor screen shot.

Hey Everyone,

When you launch a packaged HTML5 game locally, you need to go into your folder and launch ‘HTML5LaunchHelper.exe’. From there, you’ll need to open your web browser and enter the ‘local host’ information for example: http://localhost:8000//MyProject.html

Once you’ve done that, the HTML5 game should launch for you without any trouble. Some development packaged HTML5 projects will not work properly on Chrome.

Let us know if you have any further questions!

Hi ,
Local testing works thanks for that Sam.Another issue i did test was dynamic
point light for html, is great in editor [Mobile Preview]. but meshes disappear in html launch/package in game.

Hi Froffs. I’m glad to hear that 's solution worked for you. Can you please create a new post for your issue with meshes? We like to keep each post isolated to one unique issue or question. Thanks

4.9 fixed few problems, but package html5 still has a problem from my first post… If I launch by Editor it finally works on Firefox/ (before were problems with running on firefox). Also if I open ‘HTML5LaunchHelper.exe’ and enter the localhost(…) it’s working very well! You can check actual package version on [Game][1] may it works on another pc. (I know several people could play this game)


Remote servers need to have static compression in order to work. The exact name for this setting seems to differ per server type. However, it seems that most servers have the setting turned off by default.

We store data as compressed .gz files.

There is a within our system for this specific issue: UE-20600

It works for me on my local machine but when I try to upload to a hosting there is no way I can make it work… I have no idea how to config the Apache thing, and why we need that now?

I think the problem is I can’t find static compression settings on my serwer, I use phpmyadmin. On the other hand I think I have bad content in my .htaccess file. I don’t know what I should add there

AddEncoding gzip gz

Just this. It’s not simply for me :wink: copy/paste from Readme. I will continue to look for “static compression” settings. But when I’ll be at my main PC I spend more time on it. Thanks for your help!

Hi ,
On server test (hostpapa) with addencoding gzip gz to .htaccess I got an error.
See attached. Is fine on localhost any ideas.


Thank you for bringing this to our attention, this issue seems to be tied into the fact that certain websites cannot be used as a server, even for portfolio services. UE-20600 has been entered for this. This bug is not fixed as of yet, but I will inform you once it is, or you can check in with us from time to time.

Thank you!

Same issue here, 4.9.2