Problem with Swarm Agent

This problem started since I’ve updated to 4.24.2 yesterday. Once I select to build lighting only, Unreal gets stuck on “Starting up Swarm Connection… (100%)” and freezes. When opening Swarm Agent and looking at the Log, I have an error regarding host being unknown. This is what I’m getting in the Swarm Agent’s Log.

  1. 1:12:39 AM: Starting up SwarmAgent …
  2. 1:12:39 AM: … registering SwarmAgent with remoting service
  3. 1:12:39 AM: … registering SwarmAgent network channels
  4. 1:12:39 AM: [ERROR] Channel registration failed. Reason: No such host is known
  5. , Callstack: at System.Net.Dns.GetAddrInfo(String name)
  6. at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6)
  7. at System.Net.Dns.GetHostEntry(String hostNameOrAddress)
  8. at System.Runtime.Remoting.Channels.CoreChannel.GetMachineName()
  9. at System.Runtime.Remoting.Channels.CoreChannel.GetMachineIp()
  10. at System.Runtime.Remoting.Channels.Tcp.TcpServerChannel.SetupMachineName()
  11. at System.Runtime.Remoting.Channels.Tcp.TcpServerChannel…ctor(Int32 port)
  12. at Agent.AgentApplication.Main(String] args) in D:\Build++UE4\Sync\Engine\Saved\CsTools\Engine\Source\Programs\UnrealSwarm\Agent\AgentApplication.cs:line 133.

If there’s any possible fix to my problem, please let me know. Thank you.

Bumping the post

So, you can’t have foreign characters as your computer’s name. It fixed once I changed my PC name to latin.

I have this same problem. I am on windows 7. Freezes as the pop up for Starting up Swarm Connection…(100%) I’ve saved the map as a tested. It’s also on the simple UE4 3rd person map.
If I move a simple shape in the scene and try to build on the lowest preview setting it keeps freezing up? Done quite a few tests and some searches. My old UE4 still works fine on any scene and lighting build?. I have not updated since 4.20.3 on my home PC and 4.20.3 build fine as stated. 4.24.3 is the current build I’ve tried and has the freezing error.

please refer to 关于unreal engine swarm无法正常使用的一个解决方法 - 知乎

My problem was ESET Internet security firewall in automatic mode blocking the swarm TCP connection. I had to either turn off the firewall or set ESET in interactive mode and teach it some rules when it asked. But one problem is the UnrealLightmass.exe is changing its location on every job like “/SwarmCache/Jobs/job-xxxx-xxxx/UnrealLightmass.exe” so it’s not enough to teach it that rule (by allowing the exe) because it will not be valid next time. I had to instead allow the specific port it was using. Never had a similar problem with any other application for at least 5 years.