Download

Problem with Sun/Sky actor and other lights

Hi All,

I am relatively new to Unreal so if this question is rudimentary I apologize.

I have a sun/sky actor in my scene but, when it is set to any time earlier than around 7pm, none of my other lights in the scene (points, spots, etc) seem to function at all. They don’t have any visual effect in the editor window at all, and they do not bake anything into the scene. It’s like they’re literally switched off somehow. If I set the time of day in the sun/sky to evening, everything “turns on” so to speak. Is this the way it’s intended to work? Is there a way to change this?

Thanks in advance for any help.

Post screenshots of the skylight settings, directional light settings, and lightmass in World Settings. Does the skylight have a directional light assigned to it?

Screenshots below. I’m not 100% sure how to answer your other question. The skylight and directional light are both components of the SunSky actor. Is there something I can check to give you a better answer?

Thanks for the help.

The screenshots got double-posted. I’ve seen it in other posts, even triple posting of screenshots, and it’s probably not you or the other OPs doing it. Anyhow, I’m not sure what of those settings would be causing it. It sounds as though it’s due to the time of day, yet that’s definitely not how it should work because other lights wouldn’t be entirely non-functional / not casting light in a more realistic scenario. It’s like the skylight / directional is overwhelming the other lights in brightness to the extent those lights don’t work. One test to try is set the skylight and directional light higher up from where they’re currently located. So, change the Z value for each one to above 30000 at least. It’s possible that where they are currently is overlapping with the other lights somehow, and disallowing them from operating. That is usually what happens in the case of more than 4 overlapping stationary point / spot lights, but I’m not sure if it’s the case for sky and directional lights included.

Hi!
I had the same problem.
Check the directional light intensity…it’s 75.000 lux by default, it’s too high!. Change it to 10 lux.

Same problem, fixes have no effect.