Download

Problem with Static Lighting

Whenever i add static lights in my interior level and build it, the shadows come out really bad (see the screenshots). I tried playing around with lightmap resolutions and some of the settings in the details section but nothing helped except to use stationary or movable lights. Please help…

It does have uv channels 0, 1 and 2. I think the source / destination lightmap index or lightmap coordinate index affect this, but what values should i set them?

Thank you for your input!

The Generate Lightmap UV option is not checked and i didn’t change it, i guess the artist created the 3rd uv channel manually or changed the setting.

As for UV overlapping, so far i have not received an error message regarding that when building lighting.