Download

Problem with shadows in landscape

Hi, I’m struggling with a problem with my landscape. As you can see at the background that grid is darker, and if you see, in the right part there is another straight line a bit lighter. can’t solve the problem, I tried in the landscape settings with selection/unselecting cast shadows, add more examples in the lightness. Change the light of the sun to stationary and movable but anything is working… even I tried to re-example the landscape to a different grid. any suggestions?
https://forums.unrealengine.com/www.imgur.com/a/mb1bzZ5

It’s hard to tell, you’re talking about this:

line.JPG
right?

I’d try a few things:

  1. Stationary skylight and directional light - rebuild light

  2. Stationary skylight and moveable directional light - rebuilt light

  3. Try moving assets to another map

Yes, it’s that, it’s a square grid which is darker than the others, and also to the right, there is a black line that you can’t see properly in the picture. I tried everything but doesn’t work. I also try with post-processing volume, change lightmaps resolutions… and still there.

Did you try the steps above?

Yes, I’m trying everything I can get, I’m checking the materials, maybe it’s a problem with the paint layers on the landscape or something similar…

I don’t know if helps, but if I go close I can see a line like the maps are separated (?) but it’s the same landscape. Also to the left I see that I have two heightmaps

but I don’t know how to remove it

Two heighmaps not good, unless you designed it that way. Have you tried re-doing the landscape?

Do you know how I can remove it? I don’t want to redo it the landscape, it’s a huge one and there are thousand of vegetations on top, if I remove the landscape all the vegetation disappears, with weeks of work. there’s no another way? from the materials or any settings…?

Are the heightmaps overlapping?

I think so…

That may be the cause of the darkening. Kinda like doubling the color values and shadowing.

Yes, it’s that! There’s any way to remove one of the height maps??

You might be able to resize one of the height maps, or translate (move) it instead of removing one entirely. When selecting one of the height maps in the right panel (as shown in the photo), there should be settings for location and scale / size. Try that because removing one could remove more landscape data than desired.