Problem with shadows and mobility with static mesh

hello .
i have a problem with the lighting on meshes and mobility of a mesh
i will explain the problem with images

i am building a level and i created walls from the geometry panel inside the UE4
because i am not good with modeling softwares so i create each type of wall and convert it to
static mesh and when i started building the level this problem happened

i highlighted the problem
there is 3 meshes in the image one is for the door frame and the other two is just regular walls on the right and the left side of the door
you see the shadows doesn’t suppose to appear at all, also i switched the mobility of those walls to static

now when i switch the mobility of those three meshes to stationary this happened

the problem fixed
but from what i read in the forums and documentations that using a static mobility for meshes that don’t change while the game is running is best and already precalculated for

now how can i fix this problem or should i change the mobility for every mesh in the level to stationary
i tried every fix that i have found i changed the light map resolution i changed the light map coordinate index
i enabled overridden light map res
i checked the wireframe mode to find meshes that overlapping but everything looks ok for me

note : the level i’m building suppose to be inside a house so i removed the sky sphere

Those mesh will cast a shadow because that’s what’s supposed to happen ( because the door mesh IS standing out from the wall ). The only ways to stop the shadows are:

  1. Push the door flush with the wall


  1. Use a light that doesn’t cast a shadow