Problem with rig mesh import from blender

When I import a static mesh from blender, all its ok; but when I import a skeletal mesh, the material change his position and look wrong:

This is my correctly model in blender

It looks like you have the same material assigned to all slots. Look in the Skeletal Mesh editor for the material slots, you may need to Crete new ones and assign the textures for the missing ones

In Asset details.

All the parts of this character use the same texture:

I also tried to add more material slots, but I can’t:

Looks like somewhere in the process the WRONG UV set gets promoted as the main one.
In Unreal mesh import settings choose another UV Set.
Or make sure in Blender you only have one UVset to begin with.
Hope that helps…

Yup, what @minsk said :slight_smile: