Problem with Procedural Foliage Spawner

Hey everyone, first post here. I’m new to UE4 and I’m trying to follow along with the Open World Tools guide and I keep getting stuck. Whenever I complete Step 6 my UE4 freezes and I have to force close. I’m using 4.8, what am I doing wrong?

How long are you leaving it before closing it?

Also have you tried loading that tree and just placing it in a blank level? I am wondering if perhaps it is actually just building distance fields or something for the asset on load. Building distance fields for that tree can take forever.

After reading your post I let it sit for a few minutes and it actually spawned in the trees!

It was really dark under the trees so I tried to build the lighting, let that sit for a bit, then it failed. I tried it one more time and it once again failed.
I had to leave for work or I’d post the actual error message here. I think it said some kind of memory error and to try reducing the size of something. Sorry for being so vague.

Rebuilding lighting for lots of hi poly trees is going to be tricky. How many do you have??

This large world foliage stuff is mostly intended to be used with all dynamic lighting. We could not even build a small chunk of the GDC level with static lighting.

There’s a bunch, I was following the quick start guide and made an area of 100x100 to spawn the trees in.

How much RAM do you have?

If you really want to rebuild a large foliage area it could require lots of RAM. Also, you could test how much the foliage mesh itself is the bottleneck by changing the mesh to a simple editorcube or something and seeing if the rebuild still takes a while.

Are you using a lightmass importance volume?

I have 8GB of RAM, and I’m not sure about the lightmass importance volume, I haven’t messed with anything outside of what the quick start guide has told me to do so far on this project.

I am having the problem of unable to spawn when i resimulate any help would be appreciated says ensure large enough surface exists i have set to 500 x 500


I have similar problem with Procedural Foliage. When I tried to add mesh in Foliage type, Editor freeze.
I read all here, and I tried to use static mesh HillTree02 I think. When I tried to add it on ground it freeze editor also.

I use Open World Pack and 4.9.2 Unreal Editor

I work on:
Intel i5 3.1 CPU
nVidia GTX 960

What is the size of the texture? Try to add the texture after adding the type.

I am new in this.

I just tried to follow guide form official documentation, and I used mesh they suggested to use. It is mesh from Open World Collection which I downloaded from Epic Market Place.

It doesn’t happen with any other mesh I tried, except with trees meshes from Open World Collection.
I check compatibility, and they say that Open World Collection is compatible with my editor 4.9.2

Thank you for helping me.

loading HillTree_02…
finalizing load of BodySetup_7

is stuck on 74%

necro thread is necro …

But, since we are here …

I used to have the same issues when using the kitedemo stuff. Same HillTree issue, same hilltree.
i know my computer setup isnt the cause: 1800XT, 64GB PC3200, M.2 SSD on a PCiE 3.0 x16 and a 1080GTX EKWB Edition.
Resolution: Dont use HillTree_02 (there are a couple more but its been a while since i used the kitedemo for anything)

Ran into this issue today, found the location of this problem, and a workaround. The problem occurs when generating lightmap UVs, which is kicked off at MeshUtilities.cpp:2909. It appears that generating lightmap UVs is enabled by default, and I couldn’t find a way to turn it off in the Editor until after it has run during the first import (which personally I’ve never seen finish for the HillTree meshes, due to this issue…). I was able to properly load HillTree after changing that line to “if (0)”. Would be very interested to learn of a workaround that does not involve going into the source. Out of curiosity, I will also leave the initial lightmap UV generation running overnight, to see if it finishes or not.

Following up: Turns out I just wasn’t patient enough before. It took 57 minutes for Hilltree_02, but it did finish. I have verified that over 99% of that time was spent generating lightmap UVs, because when I edited MeshUtilities.cpp to disable generating lightmap UVs as described in my previous post, it took less than 1 minute.

Also interesting: In order to retry importing Hilltree_02 for the first time, I realized it was necessary to delete the cache (DerivedDataCache). It turns out that deleting the DDC in AppData/UnrealEngine/4.17 and also AppData/UnrealEngine/Common did not work. I had to delete it in the actual Engine folder. I’m not sure if this is just because I built from source.

As I mentioned before, would still be very interested to learn if there’s a way to disable generating lightmap UVs in the Editor, without going into the source. (Since this mesh took 1 hour, in theory a different mesh could take, say, 10 hours.)