Download

Problem with parts of a brush disappearing

I’m having a bit of an issue with a rather large box brush (8000x8000x50) having sections of it flicker. Funny thing was I even tried making it a static mesh and got the same problem.

You can see in the screenshots the parts where it has flickered and became see through completely. Seems to only be the sides of the tunnel that cause the issue.


The only lighting I have at the moment is the default directional light and a sunlight.

Any suggestions on what could be causing it are appreciated.

Hey Iamgoret,

It’s a little bit hard to tell from the images exactly but from the description of your problem it sounds like you may have what is called “Z-fighting.” You may have two meshes or brushes where the planes are occupying the same space causing a spastic flickering while they fight to be the one visible.

You should try moving your meshes in that area and see if you do in fact have two meshes sitting in the same place.

If you continue to have the issue try posting some images that are brighter as it would be easier to see what’s possibly going on.

Thanks!
Tim

Hi Tim!

Thanks for responding to my issue. Z-fighting was the first thing I thought of when I saw the problem so I moved the brushes about to make sure there weren’t double-ups occupying the same space.

Sorry the last screenshots were a bit dark, I’ve taken some new ones. It’s hard to capture however because it only seems to happen from a distance.

The first screenshot is close up roughly where on the wall it seems to be occurring, you can’t see the problem in the screenshot though because like I said, only happens from a distance.

The second screenshot shows the problem, the hole that appears in the wall is right down the end of the staircase, it looks like a bright segment on the left. Depending on how I move the camera (mouse) around I can get it to occur on the right side and even on the end wall panel.

Lastly you can see from the outside the huge brush I’m using as the wall of the entire stair case. I’ve actually tried using 4 smaller brushes arranged in a diagonal to cover the side wall of the staircase, had the same problem though.
3643767b1dfb845da9cefc11f8e2c5b282c0fde7.jpeg

Not sure if any of this info will be of any help, but again, thanks for the assistance.

Hey Iamgoret,

Can you give the wall/ brush some thickness? I guess worst case scenario is you could go into a 3D app and make a wall.

So I tried setting the thickness of the brush to 300 as apposed to just 50, same deal. Opened up maya, created a huge box mesh, exported it as fbx and imported it in to my map. Created UV’s within UE4, applied texture, same problem.

I also noticed depending on how I angle the camera I can make sections of the stairs disappear too, the stairs are just brushes created with the UE4 stair tool.

Starting to think it may be drivers or something like that. I even tried ramping down all my settings down from epic to low…

Uploaded a video of the problem in hopes it will help someone diagnose the issue.

Video was recorded with Nvidia shadow play… worked well!

Hey Iamgoret,

I’m not sure if this will solve your issue but it’s something worth a try to see if it will solve your issue. Going by your images above I had recreated your BSP walls and tried to match the images. However, I did not get the same artifact that you had described or was present in your video. I’m not sure if it’s a limitation of BSP or machine specs though as I am currently working off a pretty powerful machine.

Something to try though is to use smaller BSP brushes and line them up like modular walls. I’ve attached an image of a wall with 6 BSP brushes lined up.

If you’re up for it give this a show and let us know how it goes.

Thanks!

Tima98b319260642c2c65cf4fd3b05db66df17ec5c4.jpeg

Thanks Tim, I’ll certainly give that a try.
Its possible my specs aren’t powerful enough, the gear is a few years old. I’m running:
i7 3820
16gb 2133 ram over 4 channels.
2x gtx670 OC in sli.

I packaged up the project and gave it to a friend who runs AMD cards, he reported same problem.

Is it possible I could zip up the project and provide it to you?

That’s absolutely fine. I don’t mind taking a look at it and see if I can see the same issues you’re having.

Thanks!
Tim

Today we stumbled across an issue with another user that was having an issue that may be similar to yours. I’m going to attach a link so you can follow the post and potential information. (Link Here)

We are putting in a bug report for this issue as it may be related with specific graphic cards. I don’t really have any other information beyond that at the moment but as we hear anything I’ll do what I can to come back and relay that information here for you.

If you still want me to look at your level and see if the issue is happening on my machine I’d still be willing to do so.

Thanks!
Tim

Hi Tim,

Definitely looks similar (if on somewhat of a smaller scale) to what I’m experiencing.

I just need to upload the project to Dropbox or something and then I’ll provide you with a link via pm. I’ll try to get that happening tonight (Australia time).

Thanks again for looking in to this issue for me.

If at all possible would you be opposed to posting through dropbox with a link here. We want to keep this as an open topic for those in the community to offer solutions with as well. If this is a problem making your level public, if you are able to make a mockup that has the same issue I’d be willing to help you with either.

Thanks,
Tim

Yeah sure, I have no problems putting it up here. It’s very basic and I simply created it to start getting a feel for level design, I haven’t done this sort of thing before, so I’m very much a beginner. I ran in to the problem quite early so I stopped expanding on the map and all I’ve been trying to do is solve the issue.

Hopefully that works, I just grabbed the folder of the project and zipped it up.

I appear to have fixed the issue. In world settings I enabled Minimize BSPSections, and then did a rebuild of just the geometry and it instantly went away. I was actually staring at a great big hole in my mesh and it as soon as the build finished it patched it up and everything looks how it should.

Not sure what that setting does exactly, could someone please explain it’s use?

BSP gets divided based on cuts made by other brushes. Chunks of polygons are grouped together in blocks of brushes. By minimizing the sections you altered the way it groups them together, which in turn probably made the engine avoid the problem where it went wrong.

I have not read your whole thread, but brushes are very sensitive and there are a lot of hidden rules to adhere to. I take it you did something to your brush that it did not like.

UE3 and UE4 have reduced emphasis on brushes. Therefore a lot of the tools and ways of controlling brushes have also disappeared. If you look at my UE1 and UE2 tutorial from 2006 you will get a better picture on what it really is doing in the background: Hourences.com – Tutorials UE1/UE2 BSP