Problem with materials with opacity

Hi all, I’m facing a very weird problem with transparent materials. I set up my material to be translucent with the opacity value of 0.5. When I apply this material to a mesh, it becomes completely transparent. I don’t understand what is wrong here. Any help will be appreciated. I’m attaching screenshots of my material editor and the scene. Thanks in advance.

Post a picture of the main material properties.

Not sure if this is what you asked for. But here’s an image of the material details panel.

Also, this is only a problem in the scene, when in game, I can see the mesh with the set material with the right opacity. It’s still a problem for me if I can’t see it in the scene.

Right… what’s the preset set in Engine Scalability (Settings -> Scalability)? I’m quite rusty on the engine quality parameters, but I’m guessing there may be some flag that controls the rendering of translucent materials. Try setting it to Epic.

Try the material with a new project too; see if the problem is part of the project itself or the editor.

It works fine when I run the same project on another computer. I think it is my engine settings then.