Download

Problem with lightmaps

Hi there,

once again a thread about lightmaps in UE4 (4.14). I cant get rid of the seams:

513a9f4d2517b56513e76f50bd4f2395f2e3d47e.jpeg
(rendered with preview, but the seams are also in the production renders)

I created a simple box: 40040040. I created a second uv channel for the lightmap, with snapping and spacing.

3838e2de76af63184849859ae3d1c7bc81cd9cd8.jpeg

Here are also the settings:

b03bbaa302bf555193c024b3f1b248ae962a98c7.jpeg
aa7a4a4b7a43db542454920168fe665b1ca5ec14.jpeg

There is a lightmass importance volume, a directional and sky light (both stationary). Even a 1024 lightmap resolution.

Im simply dont get it.

This floor is 4*12 meters. Should i do for this a single mesh? But this modular pipeline should also work.

Link for the Mesh:

You need few settings changes on the lightmass tab:

  • Static Lighting Level Scale - 0.1
  • Indirect Lighting Quality - 3-4 (10 is hardcore)
  • Indirect lightning smoothness - 0.6

Make sure you have light portals on each window. Also I think the grid resolution of the UVs is too low, make sure the grid is the same resolution you are targeting for. Better make a 256x256 pixels grid texture, add it inside the UV unwrapping editor (on checker pattern dropdown menu, choose pick texture), and then choose “Pixel snap” (not Grid snap). Make sure that the min distance between uv islands is 2 pixels, if you want to calculate the spacing value and automize stuff 2/256 = 0.0078 this is the spacing for 2 pixels in 256 pixels grid.

Thanks. It works. I need to test this under harder conditions :wink:

Do it, you will learn a lot by testing under harder conditions. :wink:

Also, don’t construct things that way, there’s actually several ways that is more inefficient.