Download

Problem with Lighting and Auto-Exposure 5-0

Hey Guys, I am playing with some basic Light-Settings for an Outdoor lighting, but already at the very beginning I have a problem. All the time I change my “Sun” (directional light), it still looks like the post process volume has the default auto metering mode settings although I changed it. In the following video you can see my problem and my current set settings.
My aim is, when I lower the sun completly, it shall be pitch black immediatly.

Demonstration

It is because of the fog, having luminance.

If you have added a fog, make the start distance far away from the camera.

Check out this tut- it clearly shows how to fix it-

This is not an exposure problem, this is an issue with the fact that Lumen requires more time to update the global lighting than the local lighting and so instant lighting transitions like this won’t work.

First of all, thanks for the reply. I actually learned with this video :smiley:

But my fog start distance value is already 5000,0.

thanks for your reply :slight_smile: Thats a good advice, thanks for that.
But could you explain me why this “auto exposure” effect disappears when I turn off my SkyLight? I just found it when I deleted randomly my SkyLight :slight_smile:

Because you’re testing in a scene that only has a single flat plane so virtually all the indirect lighting is coming from the skylight. Without the skylight, there’s nothing to update because there’s no indirect lighting visible.

Test it in a real scene, with a lot of surfaces bouncing the sunlight around and you will see the same issue even with the skylight disabled.

1 Like

thanks! that helped me a lot :slight_smile: