Problem with export glass Substance Painter to UE4

Hi, this is my material in Substance Painter :

When I export to UE 4, look like this :

I know I have problem with export opacity, can you help me ?
This is my material on UE :

Of course unreal has its own way to create fresnel/refraction like objects (like glass, etc). So not everything you get from substance painter will work in Unreal, but they certainly can look the same, only different way to make it work.

Try to make the material look like this.

It might not meet of what you liking/expect, but you can start from there.
The key is to use Fresnel for Refraction, then change the blend mode to translucent followed with Surface ForwardShading as lighting mode in translucency.

Now look like this, in my opinion very bad :

in my blender scene look awesome :

substance painter OcclusionRoughnessMetalness compacted RGB is translated as ORM.

Red : Occlusion

Green : Roughness

Blue : Metallic

So basically you put Green and Blue channel wrong.

(if i remember correctly… maybe i’m wrong too, hey i’m not a pro or anything! Just wanted to share)

Don’t forget to open your ORM texture in UE4 and untick the SRGB option.

I forgot to mention the 2 parameters that say [1.0] and [1.3]

The [1.0] is constant, don’t change it.

[1.3] is the IOR of the fresnel. [1.0] means no light bending, more than [1.0] means more light bending.

Also probably you have to play a little bit with the roughness and opacity value since blender/substance doesn’t transfer perfectly with what UE4 renders.