Problem with destructible meshes in packaged builds.

Hi there!
I’m having a strange problem with destructible meshes, they seem to be working fine inside the editor but whenever I play the game in packaged build they start blinking as soon as they are fractured.
I have prepared a small project to reproduce the issue: here a link to it.
The engine version I’m using is 4.7.2.
In order to reproduce the problem you just have to build the project (shipping or development doesn’t make any difference) and bump into the barrels, you’ll notice that they start blinking furiously when they are destroyed.
The blueprint is quite straightforward: it simply applies damage to the mesh as soon as it’s hit by something.

I am probably doing something wrong there, I’ve been trying all day to tinker with all the different settings with no use so I really hope someone can point me to the right direction

Thanks in advance!

I have a similar issue I’m looking into over here: https://answers.unrealengine.com/questions/190896/destructile-physics-behave-weird-in-472.html#answer-195187

I’ve been able to reproduce this with 4.7, but am in the process of syncing up my latest internal build, which will take a while. I’ll update here once I have a ticket submitted.

Thank you!

Tim

Thanks, looking forward to updates on this :slight_smile:

Okay, so this one took a little longer and has been a little more involved than I original anticipated due to some errors with our internal builds producing packages that crash on start.

For the moment I’ve had to revert to a build from early February that will eventually be 4.8 to test this.

When I package the same project in 4.7 and then comparatively package that same project in 4.8 (our internal build) I’m not seeing the flickering that is happening. At this moment I believe this has been resolved internally. Until I can package on our latest internal build from a day ago. I’m not ready to mark this fully resolved just yet though.

I’ll keep an eye on our builds and try to package once the error has been resolved with our packaged builds crashing. Once I can confirm this is no longer happening with our latest I’ll mark this as fully resolved.

Thanks for your patience.

It’s good to know that this issue has been fixed in 4.8, thanks again! :slight_smile:

Hi Tim,
any news about this? Is it solved in 4.8?
Do you know which github commit solves this issue>?

I’m in the process of syncing to a build that was from yesterday. The internal builds are not able to package currently without failing, so I’ve not been able to fully test this yet. The last build I was able to package with was from some time in February. Once I get a build I can package I can confirm that the issue is resolved. Until that time I do not have a solid answer, even though that build from February did not give the same issue that is present in 4.7 I’m not closing this until I can confirm on a more recent build.

I will not have a CL for this issue, since there have been thousands of CLs since that time.

Hi Tim ! I have the same problem with destructibles. Any progress with this issue ?

UPDATE:

So I’ve managed to get a build that can package for me properly now.

I tested this on our internal build of 4.8 with CL-4505032.

The flickering is continuing to happen while the fracture chunks are not in a sleep state.

I’ve submitted ticket UE-13577 for this to be investigated.

Thank you for your patience while this is being looked into.

Tim

Small update, if you disable GPU skinning flickering dissapear.

void USkinnedMeshComponent::CreateRenderState_Concurrent()
{
  const bool bIsCPUSkinned = true;//SkelMeshResource->RequiresCPUSkinning(SceneFeatureLevel) || (GIsEditor && ShouldCPUSkin());
}

I wanted to add that I have a skeletal mesh with breakable constraints, once a constraint is broken I start getting similar visual flickering behavior on the detached mesh.
I think its related to the same problem, so just wanted to make sure you guys are aware of it.
If you think its not related, let me know and I’ll post a new question.
Thanks.

Hello.
Can you please elaborate on how can I disable GPU skinning?
Where do I find bIsCPUSkinned so I can change it to true?
I found void USkinnedMeshComponent in SkinnedMeshComponent.cpp but it is different from your code (using 4.7.6)
Thanks.

YES!!! Disabling GPU skinning fixed the problem for my project.

To find the line in code just hit ctrl+f select current project and search

void USkinnedMeshComponent::CreateRenderState_Concurrent()

This will be in the SkinnedMeshComponent.cpp file.

Then change

const bool bIsCPUSkinned = SkelMeshResource->RequiresCPUSkinning(SceneFeatureLevel) || (GIsEditor && ShouldCPUSkin());

TO

const bool bIsCPUSkinned = true; // SkelMeshResource->RequiresCPUSkinning(SceneFeatureLevel) || (GIsEditor && ShouldCPUSkin());

Then recompile your project, package, done. No flickering.

Thank you Pierdek!

I don’t know how to recompile my project.
My project is a blueprint project (no C++ code.)
Is there a way to create a solution file I can open in VS and do a compile from there?

How is this marked as resolved? 4.7.6 or 4.8.0 Preview 4, problem still there, everything is flickering like crazy.
Can’t disable GPU skinning since using static non-skinned meshes.

HI @dunenkoff This is marked as resolved because a ticket has been submitted. The question being resolved does not necessarily mean that the problem has been fixed (at least not yet), but that it has been investigated and a ticket has been submitted for a developer to take a look.

Since we include the original and any posts we come across that are related to the issue we update those posted links with any updates or fixes that have been submitted.

At the moment this one is on the to-do list to be investigated, but there is no update to report at this time. I’ve bumped the community interest for this issue.

I can confirm this still exists in 4.8.1 release build

I have the same issue on Windows. But when I move my same project to my Mac and package it for Mac, there is no blinking. (Both are 4.8.1)

any news on the subject? using the CPU skinning doesn’t fix the problem :frowning:

it seems that what is flickering is the material itself… if i remove the material from the mesh, i don’t get flickering…

it has been some time now, hasn’t anyone looked into it yet? with all the new versions coming out every month…

There is no update at the moment. I’ve updated the ticket, but that does not guarantee the issue will be addressed any more quickly.

You are correct that this is a material issue with them being assigned to the mesh. It only appears to be the interior material that I can see as well.

If this is fixed, it will be a major release (ie. 4.9, 4.10, etc), which only release every few months, vs a Hot Fix (ie. 4.8.1, 4.8.2, etc), which do not have definitive releases.

As soon as there are any updates to the ticket I will post here.